summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath/classpath-initial_0.93.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/classpath/classpath-initial_0.93.bb')
-rw-r--r--recipes-core/classpath/classpath-initial_0.93.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial_0.93.bb
new file mode 100644
index 0000000..77831c1
--- /dev/null
+++ b/recipes-core/classpath/classpath-initial_0.93.bb
@@ -0,0 +1,37 @@
1# No later version of Classpath may be used because this is the latest that can be compiled
2# by jikes!
3
4require classpath-native.inc
5
6DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
7LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
8
9DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
10
11SRC_URI += " \
12 file://autotools.patch \
13 file://miscompilation.patch \
14 "
15
16EXTRA_OECONF = " \
17 --with-jikes=jikes \
18 --with-fastjar=fastjar \
19 --with-glibj \
20 --disable-Werror \
21 --disable-local-sockets \
22 --disable-alsa \
23 --disable-gconf-peer \
24 --disable-gtk-peer \
25 --disable-plugin \
26 --disable-dssi \
27 --disable-examples \
28 --disable-tools \
29 --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \
30 --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \
31 --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \
32 --with-vm=java \
33 "
34
35SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d"
36SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945"
37