summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch')
-rw-r--r--recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch b/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
new file mode 100644
index 0000000..102e9a7
--- /dev/null
+++ b/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
@@ -0,0 +1,73 @@
1From 7833101c8c8938d58a32e355b9af1b56e4229a87 Mon Sep 17 00:00:00 2001
2From: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
3Date: Thu, 20 Aug 2020 13:50:47 +0200
4Subject: [PATCH 2/2] cacao: use system's boehm garbage collector
5
6This is a Gentoo's patch [1] to force the use of system's bdwgc.
7
8Cacao was installing an internal version of bdwgc which conflicts
9with the system's version.
10
11[1] https://gitweb.gentoo.org/proj/java.git/plain/dev-java/cacao/files/system-boehm-gc.patch
12
13Upstream-Status: Inappropriate [not author]
14
15Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
16Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
17---
18 configure.ac | 8 ++------
19 src/mm/Makefile.am | 9 ++++-----
20 2 files changed, 6 insertions(+), 11 deletions(-)
21
22diff --git a/configure.ac b/configure.ac
23index aceb2033b..db8a9770e 100644
24--- a/configure.ac
25+++ b/configure.ac
26@@ -738,6 +738,8 @@ AC_CHECK_ENABLE_GCC_PR40134
27
28 AC_CHECK_ENABLE_PIC_ASM
29
30+PKG_CHECK_MODULES([BOEHM], bdw-gc,,AC_MSG_ERROR[boehm-gc not found])
31+
32 dnl Define version numbers.
33 AC_VERSION_DETAIL
34 AC_VERSION_CONFIG
35@@ -855,12 +857,6 @@ AC_CONFIG_FILES([Makefile]
36 )
37
38
39-dnl We only build the shared library objects but we use it as
40-dnl noinst_LTLIBRARIES.
41-ac_configure_args="$ac_configure_args --disable-static"
42-AC_CONFIG_SUBDIRS(src/mm/boehm-gc)
43-
44-
45 AC_OUTPUT
46
47
48diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
49index 9d0945a29..cbd7dc963 100644
50--- a/src/mm/Makefile.am
51+++ b/src/mm/Makefile.am
52@@ -35,14 +35,13 @@ GC_FILE = \
53 endif
54
55 if ENABLE_GC_BOEHM
56-SUBDIRS = \
57- boehm-gc
58-
59 GC_FILE = \
60 gc-boehm.cpp
61
62-GC_LIB = \
63- $(top_builddir)/src/mm/boehm-gc/libgc.la
64+AM_CPPFLAGS += $(BOEHM_CFLAGS)
65+
66+GC_LIB = $(BOEHM_LIBS)
67+
68 endif
69
70 if ENABLE_GC_CACAO
71--
722.28.0
73