summaryrefslogtreecommitdiffstats
path: root/recipes-core/bcel/bcel_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/bcel/bcel_5.2.bb')
-rw-r--r--recipes-core/bcel/bcel_5.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-core/bcel/bcel_5.2.bb b/recipes-core/bcel/bcel_5.2.bb
new file mode 100644
index 0000000..c831516
--- /dev/null
+++ b/recipes-core/bcel/bcel_5.2.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Java Bytecode manipulation library"
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44030f19e8bad73725f39d16fd05ff12"
5
6SRC_URI = "http://archive.apache.org/dist/jakarta/bcel/source/${BP}-src.tar.gz"
7
8inherit java-library
9
10DEPENDS = "xerces-j regexp"
11DEPENDS_virtclass-native = "xerces-j-native regexp-native"
12
13
14do_compile() {
15 mkdir -p build
16
17 oe_makeclasspath cp -s xercesImpl regexp
18
19 javac -sourcepath src/java -d build -cp $cp `find src/java -name \*.java`
20
21 fastjar -C build -c -f ${JARFILENAME} .
22}
23
24SRC_URI[md5sum] = "905b7e718e30e7ca726530ecf106e532"
25SRC_URI[sha256sum] = "68039d59a38379d7b65ea3fc72276c43ba234776460e14361af35771bcaab295"
26
27NATIVE_INSTALL_WORKS = "1"
28BBCLASSEXTEND = "native"
29