summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2013-04-05 10:54:17 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2013-04-05 11:40:35 +0200
commit8ace2edc1db86aa4f780084c3b64fff3ebc25602 (patch)
treedf8ff581032e8961d45e6b4a92d3d5bb440648cb /recipes-extended
parent499e44455e1c37f89dfb9be9e8a970c26e1311d0 (diff)
downloadmeta-java-8ace2edc1db86aa4f780084c3b64fff3ebc25602.tar.gz
xmlpull: import package from oe-classic
* switch to ant build * use diffrent download server, original website does not have the latest tarball anymore Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xmlpull/xmlpull_1.1.3.4c.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-extended/xmlpull/xmlpull_1.1.3.4c.bb b/recipes-extended/xmlpull/xmlpull_1.1.3.4c.bb
new file mode 100644
index 0000000..16d7a42
--- /dev/null
+++ b/recipes-extended/xmlpull/xmlpull_1.1.3.4c.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "XML pull parser API"
2HOMEPAGE = "http://www.xmlpull.org"
3PRIORITY = "optional"
4SECTION = "libs"
5LICENSE = "PD"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f353e5a2416136a69a4a44ed3b761f65"
7
8DEPENDS = "ant-native"
9
10inherit java-library
11
12S = "${WORKDIR}/${PN}_1_1_3_4c"
13
14JAR = "${PN}-${PV}.jar"
15
16SRC_URI = "\
17 http://www.extreme.indiana.edu/xmlpull-website/v1/download/xmlpull_1_1_3_4c_src.tgz \
18 "
19
20do_compile() {
21 ANT_OPTS="-Dfile.encoding=iso-8859-1" ant
22}
23
24do_install() {
25 cp build/lib/${PN}_1_1_3_4c.jar ${JAR}
26}
27
28SRC_URI[md5sum] = "34c8a093e5678dd633411dfea88f8558"
29SRC_URI[sha256sum] = "e17aa1a26119966258a3656a262bbba0f0b036eecb6d9bf192cf4b497686f4c3"
30