summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-12-08 14:52:51 +0100
committerMaxin B. John <maxin.john@intel.com>2015-12-08 17:43:40 +0200
commitbac3b9acee5110390d15d38dacdb1622e31b2238 (patch)
tree1f39d7b8392576f19f77fb65f470391e2d15c6c1 /recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch
parent04d5d0bf414c05ca59618d77f17ff9898aa1c566 (diff)
downloadmeta-java-bac3b9acee5110390d15d38dacdb1622e31b2238.tar.gz
openjdk-8: add recipes for openjdk-8 and openjre-8
This adds openjdk-8 for native and target builds and allows a stripped openjre-8 being built as well instead of trying to cherry-pick jre components from jdk-image. The recipes allow building openjdk-8 with or without: * x11 * cups * alsa/pulseaudio and let packager enable unlimited-crypto, if desired. To support certificate based java libraries, cacerts is created based on ca-certificates from OE-core. Since there can be only one PROVIDES for virtual/java-native and virtual/javac-native, move the provides to openjdk-8-native (I think everyone agrees it's a better choice than ecj-bootstrap-native). Plus: Applying a fix from openjdk-9 repository which fixes build issues using gcc5 Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch')
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch b/recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch
new file mode 100644
index 0000000..92a9831
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-8/remove-shell-variables-from-autoheader.patch
@@ -0,0 +1,31 @@
1--- common/autoconf/basics.m4.orig 2015-08-17 18:02:01.642657746 +0200
2+++ common/autoconf/basics.m4 2015-08-17 18:14:44.046660616 +0200
3@@ -466,21 +466,21 @@
4 AC_SUBST(OUTPUT_ROOT, $OUTPUT_ROOT)
5
6 # Most of the probed defines are put into config.h
7- AC_CONFIG_HEADERS([$OUTPUT_ROOT/config.h:$AUTOCONF_DIR/config.h.in])
8+ AC_CONFIG_HEADERS([config.h:config.h.in])
9 # The spec.gmk file contains all variables for the make system.
10- AC_CONFIG_FILES([$OUTPUT_ROOT/spec.gmk:$AUTOCONF_DIR/spec.gmk.in])
11+ AC_CONFIG_FILES([spec.gmk:spec.gmk.in])
12 # The hotspot-spec.gmk file contains legacy variables for the hotspot make system.
13- AC_CONFIG_FILES([$OUTPUT_ROOT/hotspot-spec.gmk:$AUTOCONF_DIR/hotspot-spec.gmk.in])
14+ AC_CONFIG_FILES([hotspot-spec.gmk:hotspot-spec.gmk.in])
15 # The bootcycle-spec.gmk file contains support for boot cycle builds.
16- AC_CONFIG_FILES([$OUTPUT_ROOT/bootcycle-spec.gmk:$AUTOCONF_DIR/bootcycle-spec.gmk.in])
17+ AC_CONFIG_FILES([bootcycle-spec.gmk:bootcycle-spec.gmk.in])
18 # The compare.sh is used to compare the build output to other builds.
19- AC_CONFIG_FILES([$OUTPUT_ROOT/compare.sh:$AUTOCONF_DIR/compare.sh.in])
20+ AC_CONFIG_FILES([compare.sh:compare.sh.in])
21 # Spec.sh is currently used by compare-objects.sh
22- AC_CONFIG_FILES([$OUTPUT_ROOT/spec.sh:$AUTOCONF_DIR/spec.sh.in])
23+ AC_CONFIG_FILES([spec.sh:spec.sh.in])
24 # The generated Makefile knows where the spec.gmk is and where the source is.
25 # You can run make from the OUTPUT_ROOT, or from the top-level Makefile
26 # which will look for generated configurations
27- AC_CONFIG_FILES([$OUTPUT_ROOT/Makefile:$AUTOCONF_DIR/Makefile.in])
28+ AC_CONFIG_FILES([Makefile:Makefile.in])
29
30 # Save the arguments given to us
31 echo "$CONFIGURE_COMMAND_LINE" > $OUTPUT_ROOT/configure-arguments