summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2019-12-30 15:35:59 +0100
committerRichard Leitner <richard.leitner@skidata.com>2020-08-17 13:02:40 +0200
commit040bfc7748f37b258f8f1d2c6f1d2d44127bf173 (patch)
tree4a147312e7398d03f0f8bbffd52f71233fa91957 /recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
parent4bcf80651fa555611c13c02eaab3529ccf31bbf6 (diff)
downloadmeta-java-040bfc7748f37b258f8f1d2c6f1d2d44127bf173.tar.gz
openjdk-8: update to latest ga version 242
As OpenJDK-8 is now tagging "ga" versions in addition to the "build" version the recipes are adapted to use those "ga" versions. All existing patches got re-applied and renamed. For better handling Hotspot patches now start at patch number 1001 and jdk patches at 2001. Furthermore architecture dependent patches are prefixed with the architecture they apply on. Following patches/hunks were completely dropped: - 0002-hotspot-fix-compilation-with-security-flags-enabled.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/c40a28e54185 - 0011-hotspot-backport-patch-to-fix-misuses-of-strncpy-str.patch ostream.cpp:112 got fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f3108e56b502 - 0014-hotspot-zero-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/ca4663e58916 - 0018-hotspot-Fix-debug-build-after-8062808-Turn-on-the-Wr.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/32bc598624bd - 0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c - openjdk8-add-missing-linker-flags.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f175513c2c3a - openjdk8-fix-shark-stdc++11.patch fixed in hotspot jdk8u - openjdk8-fix-libpng-neon-build.patch fixed in jdk https://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/5d57817931e1 - aarch64-hotspot-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u Following patches were newly added: - 0011-autoconf-fix-CC-with-arguments-detection.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" - 0012-autoconf-NativeCompilation-remove-sysroot.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" Additionally add UPDATING.md which describes the openjdk8 update process for this layer and update8checksums.sh, a script that updates the openjdk8 source archive checksums in the corresponding .inc files. Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
Diffstat (limited to 'recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch')
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch b/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
deleted file mode 100644
index f9feca0..0000000
--- a/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 90220d41f65910b108c901977eefe78fc1edecc5 Mon Sep 17 00:00:00 2001
2From: Nicola Lunghi <nicola.lunghi@jci.com>
3Date: Mon, 17 Jun 2019 13:59:26 +0100
4Subject: [PATCH] Enable HotSpot builds on 5.x Linux kernels
5
68217753: Enable HotSpot builds on 5.x Linux kernels
7Summary: Remove Linux kernel version check as very unlikely a kernel older than 2.4 will be used.
8Reviewed-by: erikj
9
10Upstream-Status: Backport (http://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c)
11---
12 hotspot/make/linux/Makefile | 15 +--------------
13 1 file changed, 1 insertion(+), 14 deletions(-)
14
15diff --git a/hotspot/make/linux/Makefile b/hotspot/make/linux/Makefile
16index 17c14097..e8f20104 100644
17--- a/hotspot/make/linux/Makefile
18+++ b/hotspot/make/linux/Makefile
19@@ -227,20 +227,7 @@ all:
20 @echo " $(TARGETS_SHARK)"
21 @echo " $(TARGETS_MINIMAL1)"
22
23-checks: check_os_version check_j2se_version
24-
25-# We do not want people accidentally building on old systems (e.g. Linux 2.2.x,
26-# Solaris 2.5.1, 2.6).
27-# Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
28-
29-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
30-OS_VERSION := $(shell uname -r)
31-EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
32-
33-check_os_version:
34-ifeq ($(DISABLE_HOTSPOT_OS_VERSION_CHECK)$(EMPTY_IF_NOT_SUPPORTED),)
35- $(QUIETLY) >&2 echo "*** This OS is not supported:" `uname -a`; exit 1;
36-endif
37+checks: check_j2se_version
38
39 # jvmti.make requires XSLT (J2SE 1.4.x or newer):
40 XSLT_CHECK = $(REMOTE) $(RUN.JAVAP) javax.xml.transform.TransformerFactory
41--
422.20.1
43