summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2019-12-30 15:35:59 +0100
committerRichard Leitner <richard.leitner@skidata.com>2020-01-28 15:09:31 +0100
commit7d30e6ff7b8a54d67256ce528e8c4fd7e63f6b14 (patch)
tree398a12e3addb7470622d4cb2f98e7ad2dda02c5c /recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch
parent19b569281cc30e3aa94e772d6885cd340b1d1724 (diff)
downloadmeta-java-7d30e6ff7b8a54d67256ce528e8c4fd7e63f6b14.tar.gz
openjdk-8: update to latest ga version 242
As OpenJDK-8 is now tagging "ga" versions in addition to the "build" version the recipes are adapted to use those "ga" versions. All existing patches got re-applied and renamed. For better handling Hotspot patches now start at patch number 1001 and jdk patches at 2001. Furthermore architecture dependent patches are prefixed with the architecture they apply on. Following patches/hunks were completely dropped: - 0002-hotspot-fix-compilation-with-security-flags-enabled.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/c40a28e54185 - 0011-hotspot-backport-patch-to-fix-misuses-of-strncpy-str.patch ostream.cpp:112 got fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f3108e56b502 - 0014-hotspot-zero-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/ca4663e58916 - 0018-hotspot-Fix-debug-build-after-8062808-Turn-on-the-Wr.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/32bc598624bd - 0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c - openjdk8-add-missing-linker-flags.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f175513c2c3a - openjdk8-fix-shark-stdc++11.patch fixed in hotspot jdk8u - openjdk8-fix-libpng-neon-build.patch fixed in jdk https://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/5d57817931e1 - aarch64-hotspot-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u Following patches were newly added: - 0011-autoconf-fix-CC-with-arguments-detection.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" - 0012-autoconf-NativeCompilation-remove-sysroot.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" Additionally add UPDATING.md which describes the openjdk8 update process for this layer and update8checksums.sh, a script that updates the openjdk8 source archive checksums in the corresponding .inc files. Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
Diffstat (limited to 'recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch')
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch b/recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch
new file mode 100644
index 0000000..57099ec
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-8/0010-autoconf-remove-shell-variables-from-autoheader.patch
@@ -0,0 +1,46 @@
1From 0d22dccb4de73d274b90e2647702b92958374bc1 Mon Sep 17 00:00:00 2001
2From: Jens Rehsack <rehsack@gmail.com>
3Date: Thu, 2 Jan 2020 13:55:29 +0100
4Subject: [PATCH 10/10] autoconf: remove shell variables from autoheader
5
6Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
7---
8 common/autoconf/basics.m4 | 14 +++++++-------
9 1 file changed, 7 insertions(+), 7 deletions(-)
10
11diff --git a/common/autoconf/basics.m4 b/common/autoconf/basics.m4
12index 8e06cd2..c220bba 100644
13--- a/common/autoconf/basics.m4
14+++ b/common/autoconf/basics.m4
15@@ -661,21 +661,21 @@ AC_DEFUN_ONCE([BASIC_SETUP_OUTPUT_DIR],
16 AC_SUBST(OUTPUT_ROOT, $OUTPUT_ROOT)
17
18 # Most of the probed defines are put into config.h
19- AC_CONFIG_HEADERS([$OUTPUT_ROOT/config.h:$AUTOCONF_DIR/config.h.in])
20+ AC_CONFIG_HEADERS([config.h:config.h.in])
21 # The spec.gmk file contains all variables for the make system.
22- AC_CONFIG_FILES([$OUTPUT_ROOT/spec.gmk:$AUTOCONF_DIR/spec.gmk.in])
23+ AC_CONFIG_FILES([spec.gmk:spec.gmk.in])
24 # The hotspot-spec.gmk file contains legacy variables for the hotspot make system.
25- AC_CONFIG_FILES([$OUTPUT_ROOT/hotspot-spec.gmk:$AUTOCONF_DIR/hotspot-spec.gmk.in])
26+ AC_CONFIG_FILES([hotspot-spec.gmk:hotspot-spec.gmk.in])
27 # The bootcycle-spec.gmk file contains support for boot cycle builds.
28- AC_CONFIG_FILES([$OUTPUT_ROOT/bootcycle-spec.gmk:$AUTOCONF_DIR/bootcycle-spec.gmk.in])
29+ AC_CONFIG_FILES([bootcycle-spec.gmk:bootcycle-spec.gmk.in])
30 # The compare.sh is used to compare the build output to other builds.
31- AC_CONFIG_FILES([$OUTPUT_ROOT/compare.sh:$AUTOCONF_DIR/compare.sh.in])
32+ AC_CONFIG_FILES([compare.sh:compare.sh.in])
33 # Spec.sh is currently used by compare-objects.sh
34- AC_CONFIG_FILES([$OUTPUT_ROOT/spec.sh:$AUTOCONF_DIR/spec.sh.in])
35+ AC_CONFIG_FILES([spec.sh:spec.sh.in])
36 # The generated Makefile knows where the spec.gmk is and where the source is.
37 # You can run make from the OUTPUT_ROOT, or from the top-level Makefile
38 # which will look for generated configurations
39- AC_CONFIG_FILES([$OUTPUT_ROOT/Makefile:$AUTOCONF_DIR/Makefile.in])
40+ AC_CONFIG_FILES([Makefile:Makefile.in])
41 ])
42
43 AC_DEFUN_ONCE([BASIC_SETUP_LOGGING],
44--
452.24.1
46