summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjre-8_72b05.bb
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-12-08 14:52:51 +0100
committerMaxin B. John <maxin.john@intel.com>2015-12-08 17:43:40 +0200
commitbac3b9acee5110390d15d38dacdb1622e31b2238 (patch)
tree1f39d7b8392576f19f77fb65f470391e2d15c6c1 /recipes-core/openjdk/openjre-8_72b05.bb
parent04d5d0bf414c05ca59618d77f17ff9898aa1c566 (diff)
downloadmeta-java-bac3b9acee5110390d15d38dacdb1622e31b2238.tar.gz
openjdk-8: add recipes for openjdk-8 and openjre-8
This adds openjdk-8 for native and target builds and allows a stripped openjre-8 being built as well instead of trying to cherry-pick jre components from jdk-image. The recipes allow building openjdk-8 with or without: * x11 * cups * alsa/pulseaudio and let packager enable unlimited-crypto, if desired. To support certificate based java libraries, cacerts is created based on ca-certificates from OE-core. Since there can be only one PROVIDES for virtual/java-native and virtual/javac-native, move the provides to openjdk-8-native (I think everyone agrees it's a better choice than ecj-bootstrap-native). Plus: Applying a fix from openjdk-9 repository which fixes build issues using gcc5 Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/openjdk/openjre-8_72b05.bb')
-rw-r--r--recipes-core/openjdk/openjre-8_72b05.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjre-8_72b05.bb b/recipes-core/openjdk/openjre-8_72b05.bb
new file mode 100644
index 0000000..67eb1d3
--- /dev/null
+++ b/recipes-core/openjdk/openjre-8_72b05.bb
@@ -0,0 +1,30 @@
1require openjdk-8-release-72b05.inc
2require openjdk-8-cross.inc
3
4# some patches extracted from http://cr.openjdk.java.net/~rkennke/shark-build-hotspot/webrev.01/hotspot.patch
5# reported via http://mail.openjdk.java.net/pipermail/build-dev/2015-January/013972.html
6# by Roman Kennke (rkennke at redhat.com)
7PATCHES_URI_append = "\
8 file://openjdk8-restrict-to-staging-dir.patch;apply=no \
9 file://openjdk8-fix-shark-build.patch;apply=no \
10 file://openjdk8-fix-shark-stdc++11.patch;apply=no \
11 file://openjdk8-use_builtin_frame_address_0_rather_than_returning_address_of_local_variable.patch;apply=no \
12"
13
14do_install() {
15 do_install_jre
16}
17
18RPROVIDES_${JREPN} = "java2-vm"
19PROVIDES_${JREPN} = "java2-vm"
20RPROVIDES_${JREPN} = "java2-runtime"
21PROVIDES_${JREPN} = "java2-runtime"
22
23inherit update-alternatives
24
25ALTERNATIVE_${PN} = "java"
26ALTERNATIVE_LINK = "${bindir}/java"
27ALTERNATIVE_TARGET = "${JRE_HOME}/bin/java"
28ALTERNATIVE_PRIORITY = "100"
29
30# PR = "${INC_PR}.1"