summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjre-8_242.bb
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2019-12-30 15:35:59 +0100
committerRichard Leitner <richard.leitner@skidata.com>2020-01-28 15:09:31 +0100
commit7d30e6ff7b8a54d67256ce528e8c4fd7e63f6b14 (patch)
tree398a12e3addb7470622d4cb2f98e7ad2dda02c5c /recipes-core/openjdk/openjre-8_242.bb
parent19b569281cc30e3aa94e772d6885cd340b1d1724 (diff)
downloadmeta-java-7d30e6ff7b8a54d67256ce528e8c4fd7e63f6b14.tar.gz
openjdk-8: update to latest ga version 242
As OpenJDK-8 is now tagging "ga" versions in addition to the "build" version the recipes are adapted to use those "ga" versions. All existing patches got re-applied and renamed. For better handling Hotspot patches now start at patch number 1001 and jdk patches at 2001. Furthermore architecture dependent patches are prefixed with the architecture they apply on. Following patches/hunks were completely dropped: - 0002-hotspot-fix-compilation-with-security-flags-enabled.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/c40a28e54185 - 0011-hotspot-backport-patch-to-fix-misuses-of-strncpy-str.patch ostream.cpp:112 got fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f3108e56b502 - 0014-hotspot-zero-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/ca4663e58916 - 0018-hotspot-Fix-debug-build-after-8062808-Turn-on-the-Wr.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/32bc598624bd - 0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c - openjdk8-add-missing-linker-flags.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f175513c2c3a - openjdk8-fix-shark-stdc++11.patch fixed in hotspot jdk8u - openjdk8-fix-libpng-neon-build.patch fixed in jdk https://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/5d57817931e1 - aarch64-hotspot-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u Following patches were newly added: - 0011-autoconf-fix-CC-with-arguments-detection.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" - 0012-autoconf-NativeCompilation-remove-sysroot.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" Additionally add UPDATING.md which describes the openjdk8 update process for this layer and update8checksums.sh, a script that updates the openjdk8 source archive checksums in the corresponding .inc files. Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
Diffstat (limited to 'recipes-core/openjdk/openjre-8_242.bb')
-rw-r--r--recipes-core/openjdk/openjre-8_242.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjre-8_242.bb b/recipes-core/openjdk/openjre-8_242.bb
new file mode 100644
index 0000000..ce6392a
--- /dev/null
+++ b/recipes-core/openjdk/openjre-8_242.bb
@@ -0,0 +1,44 @@
1INC_FILE_SUFFIX = ""
2INC_FILE_SUFFIX_aarch64 = "-aarch64"
3INC_FILE_SUFFIX_armv7a = "-aarch32"
4INC_FILE_SUFFIX_armv7ve = "-aarch32"
5require openjdk-8-release${INC_FILE_SUFFIX}.inc
6require openjdk-8-cross.inc
7
8do_install() {
9 rm -rf ${D}${JRE_HOME}
10 mkdir -p ${D}${JRE_HOME}
11 cp -rp ${B}/images/j2re-image/* ${D}${JRE_HOME}
12 chown -R root:root ${D}${JRE_HOME}
13 install -m644 ${WORKDIR}/jvm.cfg ${D}${JRE_HOME}/lib/${JDK_ARCH}/
14}
15
16FILES_${PN}_append = "\
17 ${JRE_HOME}/bin/[a-z]* \
18 ${JRE_HOME}/lib/[a-z]* \
19 ${JRE_HOME}/LICENSE \
20 ${JRE_HOME}/release \
21"
22
23FILES_${PN}-dbg_append = "\
24 ${JRE_HOME}/bin/.debug/ \
25 ${JRE_HOME}/lib/.debug/ \
26 ${JRE_HOME}/lib/${JDK_ARCH}/.debug/ \
27 ${JRE_HOME}/lib/${JDK_ARCH}/jli/.debug/ \
28 ${JRE_HOME}/lib/${JDK_ARCH}/server/.debug/ \
29"
30
31FILES_${PN}-doc_append = "\
32 ${JRE_HOME}/man \
33 ${JRE_HOME}/ASSEMBLY_EXCEPTION \
34 ${JRE_HOME}/THIRD_PARTY_README \
35"
36
37RPROVIDES_${PN} = "java2-runtime"
38
39inherit update-alternatives
40
41ALTERNATIVE_${PN} = "java"
42ALTERNATIVE_LINK_NAME[java] = "${bindir}/java"
43ALTERNATIVE_TARGET[java] = "${JRE_HOME}/bin/java"
44ALTERNATIVE_PRIORITY[java] = "100"