summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-8_242.bb
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2019-12-30 15:35:59 +0100
committerRichard Leitner <richard.leitner@skidata.com>2020-01-27 11:02:06 +0100
commitcb6eedeb1f7fa877497e6ff2aa893e8089fe6541 (patch)
treeba4b6977735e331c5cb6a7585a185fba895f2dc7 /recipes-core/openjdk/openjdk-8_242.bb
parent19b569281cc30e3aa94e772d6885cd340b1d1724 (diff)
downloadmeta-java-cb6eedeb1f7fa877497e6ff2aa893e8089fe6541.tar.gz
openjdk-8: update to latest ga version 242
As OpenJDK-8 is now tagging "ga" versions in addition to the "build" version the recipes are adapted to use those "ga" versions. All existing patches got re-applied and renamed. For better handling Hotspot patches now start at patch number 1001 and jdk patches at 2001. Furthermore architecture dependent patches are prefixed with the architecture they apply on. Following patches/hunks were completely dropped: - 0002-hotspot-fix-compilation-with-security-flags-enabled.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/c40a28e54185 - 0011-hotspot-backport-patch-to-fix-misuses-of-strncpy-str.patch ostream.cpp:112 got fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f3108e56b502 - 0014-hotspot-zero-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/ca4663e58916 - 0018-hotspot-Fix-debug-build-after-8062808-Turn-on-the-Wr.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/32bc598624bd - 0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c - openjdk8-add-missing-linker-flags.patch fixed in hotspot jdk8u https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/f175513c2c3a - openjdk8-fix-shark-stdc++11.patch fixed in hotspot jdk8u - openjdk8-fix-libpng-neon-build.patch fixed in jdk https://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/5d57817931e1 - aarch64-hotspot-fix-undefined-behaviour-gcc-v8-fix.patch got backported to hotspot jdk8u Following patches were newly added: - 0011-autoconf-fix-CC-with-arguments-detection.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" - 0012-autoconf-NativeCompilation-remove-sysroot.patch needed because of jdk8u commit "8038340: Cleanup and fix sysroot and devkit handling on Linux and Solaris" Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
Diffstat (limited to 'recipes-core/openjdk/openjdk-8_242.bb')
-rw-r--r--recipes-core/openjdk/openjdk-8_242.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-8_242.bb b/recipes-core/openjdk/openjdk-8_242.bb
new file mode 100644
index 0000000..bc6ce51
--- /dev/null
+++ b/recipes-core/openjdk/openjdk-8_242.bb
@@ -0,0 +1,61 @@
1INC_FILE_SUFFIX = ""
2INC_FILE_SUFFIX_aarch64 = "-aarch64"
3INC_FILE_SUFFIX_armv7a = "-aarch32"
4INC_FILE_SUFFIX_armv7ve = "-aarch32"
5require openjdk-8-release${INC_FILE_SUFFIX}.inc
6require openjdk-8-cross.inc
7
8do_install() {
9 rm -rf ${D}${JDK_HOME}
10 mkdir -p ${D}${JDK_HOME}
11 cp -rp ${B}/images/j2sdk-image/* ${D}${JDK_HOME}
12 chown -R root:root ${D}${JDK_HOME}
13 install -m644 ${WORKDIR}/jvm.cfg ${D}${JDK_HOME}/jre/lib/${JDK_ARCH}/
14 find ${D}${JDK_HOME} -name "*.debuginfo" -exec rm {} \;
15}
16
17PACKAGES_append = " \
18 ${PN}-demo \
19 ${PN}-source \
20"
21
22FILES_${PN}_append = "\
23 ${JDK_HOME}/bin/[a-z]* \
24 ${JDK_HOME}/lib/[a-z]* \
25 ${JDK_HOME}/jre/bin/[a-z]* \
26 ${JDK_HOME}/jre/lib/[a-z]* \
27 ${JDK_HOME}/LICENSE \
28 ${JDK_HOME}/jre/LICENSE \
29 ${JDK_HOME}/release \
30"
31
32FILES_${PN}-dev_append = "\
33 ${JDK_HOME}/include \
34"
35
36FILES_${PN}-demo = " ${JDK_HOME}/demo ${JDK_HOME}/sample "
37RDEPENDS_${PN}-demo = " ${PN} "
38
39FILES_${PN}-doc_append = "\
40 ${JDK_HOME}/man \
41 ${JDK_HOME}/ASSEMBLY_EXCEPTION \
42 ${JDK_HOME}/THIRD_PARTY_README \
43 ${JDK_HOME}/jre/ASSEMBLY_EXCEPTION \
44 ${JDK_HOME}/jre/THIRD_PARTY_README \
45 ${JDK_HOME}/man \
46"
47
48FILES_${PN}-source = " ${JDK_HOME}/src.zip "
49
50RPROVIDES_${PN} = "java2-runtime"
51
52inherit update-alternatives
53
54ALTERNATIVE_PRIORITY = "100"
55
56ALTERNATIVE_${PN} = "java javac"
57ALTERNATIVE_LINK_NAME[java] = "${bindir}/java"
58ALTERNATIVE_TARGET[java] = "${JDK_HOME}/bin/java"
59
60ALTERNATIVE_LINK_NAME[javac] = "${bindir}/javac"
61ALTERNATIVE_TARGET[javac] = "${JDK_HOME}/bin/javac"