summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2015-10-30 10:36:28 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-10-30 08:59:12 -0200
commitd111fae12343f0a79148ea370a45b308ee8b36cf (patch)
treedf2555af4e74ec69e893ea434b9f43f23711988b /recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
parenta88718b6a6ec2a9429cbfd364d590ae69eb661e4 (diff)
downloadmeta-java-d111fae12343f0a79148ea370a45b308ee8b36cf.tar.gz
openjdk-7: remove openjdk-7-release-*.inc
Due to the fact we will always support only one OpenJDK 7 version the openjdk-7-release-*.inc is not needed. Therefore remove this file and split it content to openjdk-7_*.bb and openjdk-7-common.inc. Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb')
-rw-r--r--recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb33
1 files changed, 32 insertions, 1 deletions
diff --git a/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb b/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
index df91e4d..92613a2 100644
--- a/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
+++ b/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
@@ -1,4 +1,8 @@
1require openjdk-7-release-91b01.inc 1require openjdk-7-common.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5FILESPATH =. "${FILE_DIRNAME}/patches-openjdk-7:"
2 6
3inherit distro_features_check 7inherit distro_features_check
4 8
@@ -37,3 +41,30 @@ SRC_URI[openjdk.sha256sum] = "c1e6924bddff0ddec318364c60f4e0843c1186a0aa9911ce6c
37HOTSPOT_CHANGESET = "3f1b4a1fe4a2" 41HOTSPOT_CHANGESET = "3f1b4a1fe4a2"
38SRC_URI[hotspot.md5sum] = "106b2ec0a8798fbe07f3d838568bd0d8" 42SRC_URI[hotspot.md5sum] = "106b2ec0a8798fbe07f3d838568bd0d8"
39SRC_URI[hotspot.sha256sum] = "39bc54bf343e1dce404b8c95285c0457a8d0a7c7aedfb55055aff9795dd36a85" 43SRC_URI[hotspot.sha256sum] = "39bc54bf343e1dce404b8c95285c0457a8d0a7c7aedfb55055aff9795dd36a85"
44
45###############################################################################
46# PATCHES - split up to allow overriding them separately
47OEPATCHES = "\
48 file://build-hacks.patch \
49 file://fix_hotspot_crosscompile.patch \
50 "
51
52ICEDTEAPATCHES = "\
53 file://icedtea-zero-hotspotfix.patch;apply=no \
54 file://icedtea-jdk-nio-use-host-cc.patch;apply=no \
55 file://icedtea-jdk-build-nio-gensor-genuc-gensc-static.patch;apply=no \
56 file://icedtea-jdk-rmi-crosscompile.patch;apply=no \
57 file://icedtea-crosscompile-fix.patch;apply=no \
58 file://icedtea-xawt-crosscompile-fix.patch;apply=no \
59 "
60
61DISTRIBUTION_PATCHES = "\
62 patches/icedtea-zero-hotspotfix.patch \
63 patches/icedtea-jdk-nio-use-host-cc.patch \
64 patches/icedtea-jdk-build-nio-gensor-genuc-gensc-static.patch \
65 patches/icedtea-jdk-rmi-crosscompile.patch \
66 patches/icedtea-crosscompile-fix.patch \
67 patches/icedtea-xawt-crosscompile-fix.patch \
68 "
69
70export DISTRIBUTION_PATCHES