summaryrefslogtreecommitdiffstats
path: root/recipes-core/jcraft
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/jcraft
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/jcraft')
-rw-r--r--recipes-core/jcraft/jsch_0.1.40.bb31
-rw-r--r--recipes-core/jcraft/jzlib_1.0.7.bb24
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-core/jcraft/jsch_0.1.40.bb b/recipes-core/jcraft/jsch_0.1.40.bb
new file mode 100644
index 0000000..afb84d6
--- /dev/null
+++ b/recipes-core/jcraft/jsch_0.1.40.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "SSH implementation in Java"
2HOMEPAGE = "http://www.jcraft.com/jsch"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55e3b6a0987ccd0c34530f3df2d206ae"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip"
7
8inherit java-library
9
10DEPENDS = "jzlib"
11DEPENDS_virtclass-native = "jzlib-native"
12
13RDEPENDS_${PN} = "libjzlib-java"
14RDEPENDS_${PN}_virtclass-native = ""
15
16do_compile() {
17 mkdir -p build
18
19 oe_makeclasspath cp -s jzlib
20
21 javac -sourcepath src -cp $cp -d build `find src -name "*.java"`
22
23 fastjar -C build -c -f ${JARFILENAME} .
24}
25
26SRC_URI[md5sum] = "b59cec19a487e95aed68378976b4b566"
27SRC_URI[sha256sum] = "ca9d2ae08fd7a8983fb00d04f0f0c216a985218a5eb364ff9bee73870f28e097"
28
29NATIVE_INSTALL_WORKS = "1"
30BBCLASSEXTEND = "native"
31
diff --git a/recipes-core/jcraft/jzlib_1.0.7.bb b/recipes-core/jcraft/jzlib_1.0.7.bb
new file mode 100644
index 0000000..5eb390c
--- /dev/null
+++ b/recipes-core/jcraft/jzlib_1.0.7.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "zlib implementation in Java"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a2b2e5b95bf768dd5c4ca097c9cde9e9"
4
5HOMEPAGE = "http://www.jcraft.com/jzlib"
6
7SRC_URI = "http://www.jcraft.com/jzlib/jzlib-${PV}.tar.gz"
8
9inherit java-library
10
11do_compile() {
12 mkdir -p build
13
14 javac -sourcepath . -d build `find com -name "*.java"`
15
16 fastjar -C build -c -f ${JARFILENAME} .
17}
18
19SRC_URI[md5sum] = "3c52a0afb970e8a1fb2d34f30d330a83"
20SRC_URI[sha256sum] = "20923a3f771a14c58c8cddfff2b589d568aff09f8a931919dc63ddaabb32407a"
21
22NATIVE_INSTALL_WORKS = "1"
23BBCLASSEXTEND = "native"
24