summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-31 19:20:25 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-08-16 09:19:32 +0200
commitdefa36fd9c0722b30ab9981bce0905c7d5153a64 (patch)
tree2d2989985ce596dd76bd2a33498551345184997a /recipes-core/icedtea
parentda0b3a20a67496dc8d4282d19a60672001b7f825 (diff)
downloadmeta-java-defa36fd9c0722b30ab9981bce0905c7d5153a64.tar.gz
icedtea-native: Fix build on ubuntu 12.04 release
It conflicts definitions from standard include so backport a patch from upstream When here also change the LICENSE field to be more compatible to avoid warnings like WARNING: icedtea6-native: No generic license file exists for: GPL in any provider WARNING: icedtea6-native: No generic license file exists for: with in any provider WARNING: icedtea6-native: No generic license file exists for: Classpath in any provider WARNING: icedtea6-native: No generic license file exists for: Exception in any provider Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'recipes-core/icedtea')
-rw-r--r--recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-jdk-avoid-cdef-collision.patch203
-rw-r--r--recipes-core/icedtea/icedtea6-native.inc2
-rw-r--r--recipes-core/icedtea/icedtea6-native_1.8.11.bb4
3 files changed, 207 insertions, 2 deletions
diff --git a/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-jdk-avoid-cdef-collision.patch b/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-jdk-avoid-cdef-collision.patch
new file mode 100644
index 0000000..023ce4d
--- /dev/null
+++ b/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-jdk-avoid-cdef-collision.patch
@@ -0,0 +1,203 @@
1Fixes collisions with standard namespace
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Backport
5
6Index: openjdk/hotspot/src/share/vm/opto/addnode.cpp
7===================================================================
8--- openjdk/hotspot/src/share/vm/opto/addnode.cpp 2010-02-16 19:11:09.000000000 -0800
9+++ openjdk/hotspot/src/share/vm/opto/addnode.cpp 2012-07-30 15:54:25.999551792 -0700
10@@ -27,8 +27,6 @@
11 #include "incls/_precompiled.incl"
12 #include "incls/_addnode.cpp.incl"
13
14-#define MAXFLOAT ((float)3.40282346638528860e+38)
15-
16 // Classic Add functionality. This covers all the usual 'add' behaviors for
17 // an algebraic ring. Add-integer, add-float, add-double, and binary-or are
18 // all inherited from this class. The various identity values are supplied
19Index: openjdk/hotspot/src/share/vm/prims/jniCheck.cpp
20===================================================================
21--- openjdk/hotspot/src/share/vm/prims/jniCheck.cpp 2010-02-16 19:11:10.000000000 -0800
22+++ openjdk/hotspot/src/share/vm/prims/jniCheck.cpp 2012-07-30 16:05:20.779549364 -0700
23@@ -80,7 +80,7 @@
24 if (env != xenv) { \
25 NativeReportJNIFatalError(thr, warn_wrong_jnienv); \
26 } \
27- __ENTRY(result_type, header, thr)
28+ VM_ENTRY_BASE(result_type, header, thr)
29
30
31 #define UNCHECKED() (unchecked_jni_NativeInterface)
32Index: openjdk/hotspot/src/share/vm/prims/jvmtiEnter.xsl
33===================================================================
34--- openjdk/hotspot/src/share/vm/prims/jvmtiEnter.xsl 2010-02-16 19:11:10.000000000 -0800
35+++ openjdk/hotspot/src/share/vm/prims/jvmtiEnter.xsl 2012-07-30 16:03:50.491550815 -0700
36@@ -424,7 +424,7 @@
37 <xsl:value-of select="$space"/>
38 <xsl:text>ThreadInVMfromNative __tiv(current_thread);</xsl:text>
39 <xsl:value-of select="$space"/>
40- <xsl:text>__ENTRY(jvmtiError, </xsl:text>
41+ <xsl:text>VM_ENTRY_BASE(jvmtiError, </xsl:text>
42 <xsl:apply-templates select="." mode="functionid"/>
43 <xsl:text> , current_thread)</xsl:text>
44 <xsl:value-of select="$space"/>
45Index: openjdk/hotspot/src/share/vm/prims/jvmtiEnv.cpp
46===================================================================
47--- openjdk/hotspot/src/share/vm/prims/jvmtiEnv.cpp 2010-02-16 19:11:10.000000000 -0800
48+++ openjdk/hotspot/src/share/vm/prims/jvmtiEnv.cpp 2012-07-30 16:04:03.683550594 -0700
49@@ -126,7 +126,7 @@
50 // from native so as to resolve the jthread.
51
52 ThreadInVMfromNative __tiv(current_thread);
53- __ENTRY(jvmtiError, JvmtiEnv::GetThreadLocalStorage , current_thread)
54+ VM_ENTRY_BASE(jvmtiError, JvmtiEnv::GetThreadLocalStorage , current_thread)
55 debug_only(VMNativeEntryWrapper __vew;)
56
57 oop thread_oop = JNIHandles::resolve_external_guard(thread);
58Index: openjdk/hotspot/src/share/vm/prims/jvmtiExport.cpp
59===================================================================
60--- openjdk/hotspot/src/share/vm/prims/jvmtiExport.cpp 2010-02-16 19:11:10.000000000 -0800
61+++ openjdk/hotspot/src/share/vm/prims/jvmtiExport.cpp 2012-07-30 15:59:43.175550785 -0700
62@@ -345,7 +345,7 @@
63 JavaThread* current_thread = (JavaThread*) ThreadLocalStorage::thread();
64 // transition code: native to VM
65 ThreadInVMfromNative __tiv(current_thread);
66- __ENTRY(jvmtiEnv*, JvmtiExport::get_jvmti_interface, current_thread)
67+ VM_ENTRY_BASE(jvmtiEnv*, JvmtiExport::get_jvmti_interface, current_thread)
68 debug_only(VMNativeEntryWrapper __vew;)
69
70 JvmtiEnv *jvmti_env = JvmtiEnv::create_a_jvmti(version);
71Index: openjdk/hotspot/src/share/vm/runtime/interfaceSupport.hpp
72===================================================================
73--- openjdk/hotspot/src/share/vm/runtime/interfaceSupport.hpp 2010-02-16 19:11:10.000000000 -0800
74+++ openjdk/hotspot/src/share/vm/runtime/interfaceSupport.hpp 2012-07-30 16:36:53.391544578 -0700
75@@ -46,7 +46,7 @@
76 }
77 };
78
79-// InterfaceSupport provides functionality used by the __LEAF and __ENTRY
80+// InterfaceSupport provides functionality used by the VM_LEAF_BASE and VM_ENTRY_BASE
81 // macros. These macros are used to guard entry points into the VM and
82 // perform checks upon leave of the VM.
83
84@@ -391,7 +391,7 @@
85
86 // LEAF routines do not lock, GC or throw exceptions
87
88-#define __LEAF(result_type, header) \
89+#define VM_LEAF_BASE(result_type, header) \
90 TRACE_CALL(result_type, header) \
91 debug_only(NoHandleMark __hm;) \
92 /* begin of body */
93@@ -399,7 +399,7 @@
94
95 // ENTRY routines may lock, GC and throw exceptions
96
97-#define __ENTRY(result_type, header, thread) \
98+#define VM_ENTRY_BASE(result_type, header, thread) \
99 TRACE_CALL(result_type, header) \
100 HandleMarkCleaner __hm(thread); \
101 Thread* THREAD = thread; \
102@@ -421,20 +421,20 @@
103 #define IRT_ENTRY(result_type, header) \
104 result_type header { \
105 ThreadInVMfromJava __tiv(thread); \
106- __ENTRY(result_type, header, thread) \
107+ VM_ENTRY_BASE(result_type, header, thread) \
108 debug_only(VMEntryWrapper __vew;)
109
110
111 #define IRT_LEAF(result_type, header) \
112 result_type header { \
113- __LEAF(result_type, header) \
114+ VM_LEAF_BASE(result_type, header) \
115 debug_only(No_Safepoint_Verifier __nspv(true);)
116
117
118 #define IRT_ENTRY_NO_ASYNC(result_type, header) \
119 result_type header { \
120 ThreadInVMfromJavaNoAsyncException __tiv(thread); \
121- __ENTRY(result_type, header, thread) \
122+ VM_ENTRY_BASE(result_type, header, thread) \
123 debug_only(VMEntryWrapper __vew;)
124
125 // Another special case for nmethod_entry_point so the nmethod that the
126@@ -445,7 +445,7 @@
127 result_type header { \
128 nmethodLocker _nmlock(nm); \
129 ThreadInVMfromJavaNoAsyncException __tiv(thread); \
130- __ENTRY(result_type, header, thread)
131+ VM_ENTRY_BASE(result_type, header, thread)
132
133 #define IRT_END }
134
135@@ -455,20 +455,20 @@
136 #define JRT_ENTRY(result_type, header) \
137 result_type header { \
138 ThreadInVMfromJava __tiv(thread); \
139- __ENTRY(result_type, header, thread) \
140+ VM_ENTRY_BASE(result_type, header, thread) \
141 debug_only(VMEntryWrapper __vew;)
142
143
144 #define JRT_LEAF(result_type, header) \
145 result_type header { \
146- __LEAF(result_type, header) \
147+ VM_LEAF_BASE(result_type, header) \
148 debug_only(JRT_Leaf_Verifier __jlv;)
149
150
151 #define JRT_ENTRY_NO_ASYNC(result_type, header) \
152 result_type header { \
153 ThreadInVMfromJavaNoAsyncException __tiv(thread); \
154- __ENTRY(result_type, header, thread) \
155+ VM_ENTRY_BASE(result_type, header, thread) \
156 debug_only(VMEntryWrapper __vew;)
157
158 // Same as JRT Entry but allows for return value after the safepoint
159@@ -501,7 +501,7 @@
160 assert( !VerifyJNIEnvThread || (thread == Thread::current()), "JNIEnv is only valid in same thread"); \
161 ThreadInVMfromNative __tiv(thread); \
162 debug_only(VMNativeEntryWrapper __vew;) \
163- __ENTRY(result_type, header, thread)
164+ VM_ENTRY_BASE(result_type, header, thread)
165
166
167 // Ensure that the VMNativeEntryWrapper constructor, which can cause
168@@ -521,7 +521,7 @@
169 result_type JNICALL header { \
170 JavaThread* thread=JavaThread::thread_from_jni_environment(env); \
171 assert( !VerifyJNIEnvThread || (thread == Thread::current()), "JNIEnv is only valid in same thread"); \
172- __LEAF(result_type, header)
173+ VM_LEAF_BASE(result_type, header)
174
175
176 // Close the routine and the extern "C"
177@@ -537,7 +537,7 @@
178 JavaThread* thread=JavaThread::thread_from_jni_environment(env); \
179 ThreadInVMfromNative __tiv(thread); \
180 debug_only(VMNativeEntryWrapper __vew;) \
181- __ENTRY(result_type, header, thread)
182+ VM_ENTRY_BASE(result_type, header, thread)
183
184
185 #define JVM_ENTRY_NO_ENV(result_type, header) \
186@@ -546,7 +546,7 @@
187 JavaThread* thread = (JavaThread*)ThreadLocalStorage::thread(); \
188 ThreadInVMfromNative __tiv(thread); \
189 debug_only(VMNativeEntryWrapper __vew;) \
190- __ENTRY(result_type, header, thread)
191+ VM_ENTRY_BASE(result_type, header, thread)
192
193
194 #define JVM_QUICK_ENTRY(result_type, header) \
195@@ -562,7 +562,7 @@
196 extern "C" { \
197 result_type JNICALL header { \
198 VM_Exit::block_if_vm_exited(); \
199- __LEAF(result_type, header)
200+ VM_LEAF_BASE(result_type, header)
201
202
203 #define JVM_END } }
diff --git a/recipes-core/icedtea/icedtea6-native.inc b/recipes-core/icedtea/icedtea6-native.inc
index 700bfb0..1414ac3 100644
--- a/recipes-core/icedtea/icedtea6-native.inc
+++ b/recipes-core/icedtea/icedtea6-native.inc
@@ -1,6 +1,6 @@
1DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools" 1DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools"
2HOMEPAGE = "http://icedtea.classpath.org" 2HOMEPAGE = "http://icedtea.classpath.org"
3LICENSE = "GPL with Classpath Exception" 3LICENSE = "GPL-2.0-with-classpath-exception"
4INC_PR = "r5" 4INC_PR = "r5"
5 5
6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ 6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \
diff --git a/recipes-core/icedtea/icedtea6-native_1.8.11.bb b/recipes-core/icedtea/icedtea6-native_1.8.11.bb
index 4e3ff27..7c2e6ea 100644
--- a/recipes-core/icedtea/icedtea6-native_1.8.11.bb
+++ b/recipes-core/icedtea/icedtea6-native_1.8.11.bb
@@ -4,7 +4,7 @@ require ${PN}.inc
4 4
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6 6
7PR = "${INC_PR}.1" 7PR = "${INC_PR}.2"
8 8
9SRC_URI = "\ 9SRC_URI = "\
10 http://icedtea.classpath.org/download/source/icedtea6-${PV}.tar.gz;name=iced \ 10 http://icedtea.classpath.org/download/source/icedtea6-${PV}.tar.gz;name=iced \
@@ -43,6 +43,7 @@ ICEDTEA_PATCHES = "\
43 file://icedtea-hotspot-make-arch-sane-for-x86.patch;apply=no \ 43 file://icedtea-hotspot-make-arch-sane-for-x86.patch;apply=no \
44 file://icedtea-jdk-sane-x86-arch.patch;apply=no \ 44 file://icedtea-jdk-sane-x86-arch.patch;apply=no \
45 file://icedtea-unbreak-float.patch;apply=no \ 45 file://icedtea-unbreak-float.patch;apply=no \
46 file://icedtea-jdk-avoid-cdef-collision.patch;apply=no \
46 " 47 "
47 48
48export DISTRIBUTION_PATCHES = "\ 49export DISTRIBUTION_PATCHES = "\
@@ -52,6 +53,7 @@ export DISTRIBUTION_PATCHES = "\
52 patches/icedtea-hotspot-make-arch-sane-for-x86.patch \ 53 patches/icedtea-hotspot-make-arch-sane-for-x86.patch \
53 patches/icedtea-jdk-sane-x86-arch.patch \ 54 patches/icedtea-jdk-sane-x86-arch.patch \
54 patches/icedtea-unbreak-float.patch \ 55 patches/icedtea-unbreak-float.patch \
56 patches/icedtea-jdk-avoid-cdef-collision.patch \
55 " 57 "
56 58
57EXTRA_OECONF += " --with-jaxws-drop-zip=${DL_DIR}/jdk6-jaxws-2009_10_27.zip \ 59EXTRA_OECONF += " --with-jaxws-drop-zip=${DL_DIR}/jdk6-jaxws-2009_10_27.zip \