summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpathx/gnumail_1.1.2.bb
diff options
context:
space:
mode:
authorErkka Kääriä <erkka.kaaria@intel.com>2015-12-10 10:45:45 +0200
committerMaxin B. John <maxin.john@intel.com>2015-12-11 15:07:25 +0200
commita7586e45a2b89ab8ce66ac00a54c0223f08f6804 (patch)
treef2dcabef5c20898ad66f5469f551fd279ade86de /recipes-core/classpathx/gnumail_1.1.2.bb
parentbac3b9acee5110390d15d38dacdb1622e31b2238 (diff)
downloadmeta-java-a7586e45a2b89ab8ce66ac00a54c0223f08f6804.tar.gz
gnumail: Fix race condition in makefile
Parallel make does not handle multiple javac invocations correctly, as javac compiles any uncompiled dependencies on its own. This leads to a race condition where make may see incomplete class files and incorrectly assume that the class files has already been compiled. This ultimately causes incomplete class files to be included in one of the jars, causing build failures later one when javac attempts to use such class file. This issue is fixed by patching the makefile so that only one instance of javac is invoked, which compiles all the java files in one go. Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/classpathx/gnumail_1.1.2.bb')
-rw-r--r--recipes-core/classpathx/gnumail_1.1.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-core/classpathx/gnumail_1.1.2.bb b/recipes-core/classpathx/gnumail_1.1.2.bb
index 41417c0..b498c2b 100644
--- a/recipes-core/classpathx/gnumail_1.1.2.bb
+++ b/recipes-core/classpathx/gnumail_1.1.2.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=14bc6ee8b2e2b409be599212867d126e"
6 6
7SRC_URI = "http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \ 7SRC_URI = "http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \
8 file://datadir_java.patch \ 8 file://datadir_java.patch \
9 file://fix_makefile_race_condition.patch \
9 " 10 "
10 11
11inherit java-library java-bootstrap-components autotools 12inherit java-library java-bootstrap-components autotools