summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath/classpath-native_0.99.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-07-18 22:48:50 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-07-19 17:37:39 +0200
commitea76b80108b4c292379e37e01cdbb9d984d74759 (patch)
tree8b3d9567925bfaaaa295e396c6f2ecb907356afe /recipes-core/classpath/classpath-native_0.99.bb
parent817d88937ea7fed7d8812ba905a88e2c24d661d7 (diff)
downloadmeta-java-ea76b80108b4c292379e37e01cdbb9d984d74759.tar.gz
classpath: update to version 0.99
* switch to INC_PR for native and initial * clean up dependencies * inherit gettext class instead of depeding directly on the package * clean up patches
Diffstat (limited to 'recipes-core/classpath/classpath-native_0.99.bb')
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
new file mode 100644
index 0000000..ece10c3
--- /dev/null
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -0,0 +1,32 @@
1require classpath-native.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4DEPENDS += "ecj-initial"
5
6PR = "${INC_PR}.0"
7
8SRC_URI += " \
9 file://sun-security-getproperty.patch;striplevel=0 \
10 file://ecj_java_dir.patch \
11 file://autotools.patch \
12 file://miscompilation.patch \
13 file://toolwrapper-exithook.patch \
14 "
15
16# tools using java-initial rather than java sed it out
17do_compile_append () {
18
19 COMMANDS="gappletviewer gjarsigner gkeytool \
20 gjar gnative2ascii gserialver grmiregistry \
21 gtnameserv gorbd grmid grmic gjavah \
22 "
23
24 for i in ${COMMANDS};
25 do
26 sed -i -e "s/java-initial/java/g" tools/${i}
27 done
28}
29
30SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
31SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"
32