summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/cacao
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/cacao')
-rw-r--r--recipes-core/cacao/cacaoh-openjdk-native.inc31
-rw-r--r--recipes-core/cacao/cacaoh-openjdk-native_0.99.4.bb7
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-core/cacao/cacaoh-openjdk-native.inc b/recipes-core/cacao/cacaoh-openjdk-native.inc
new file mode 100644
index 0000000..fcc38ad
--- /dev/null
+++ b/recipes-core/cacao/cacaoh-openjdk-native.inc
@@ -0,0 +1,31 @@
1DESCRIPTION = "Header generator for Cacao JVM - Needed for cross-compilation builds"
2HOMEPAGE = "http://www.cacaojvm.org/"
3LICENSE = "GPL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6DEPENDS = "libtool-native zlib-native virtual/javac-native classpath-native icedtea6-native"
7
8S = "${WORKDIR}/cacao-${PV}"
9
10inherit java autotools native
11
12EXTRA_OECONF = " \
13 --with-java-runtime-library=openjdk \
14 --with-java-runtime-library-classes=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/jre/lib/rt.jar \
15 --with-jni_md_h=${STAGING_INCDIR}/classpath \
16 --with-jni_h=${STAGING_INCDIR}/classpath \
17 --with-hpi_md_h=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/include/hpi \
18 --with-hpi_h=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/include/hpi \
19 "
20
21do_compile() {
22 # Compile the header generator only (and what is needed for it).
23 oe_runmake -C src/toolbox libtoolbox.la
24 oe_runmake -C src/vmcore libvmcore.la
25 oe_runmake -C src/cacaoh cacaoh
26}
27
28do_install() {
29 install -d ${D}${bindir}/cacaoh-${PV}
30 ${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool --mode=install install -m 0755 src/cacaoh/cacaoh ${D}/${bindir}/cacaoh-openjdk-${PV}
31}
diff --git a/recipes-core/cacao/cacaoh-openjdk-native_0.99.4.bb b/recipes-core/cacao/cacaoh-openjdk-native_0.99.4.bb
new file mode 100644
index 0000000..2e7ff93
--- /dev/null
+++ b/recipes-core/cacao/cacaoh-openjdk-native_0.99.4.bb
@@ -0,0 +1,7 @@
1require cacaoh-openjdk-native.inc
2
3SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2"
4
5SRC_URI[md5sum] = "63220327925ace13756ae334c55a3baa"
6SRC_URI[sha256sum] = "1dfc4903dc0172286df4f1740fd0f12749ac81d51c602290b47cbe83d51e1d56"
7