summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/files
diff options
context:
space:
mode:
authorHenning Heinold <henning@itconsulting-heinold.de>2014-01-03 21:42:17 +0100
committerHenning Heinold <henning@itconsulting-heinold.de>2014-01-09 01:25:35 +0100
commitb229a38bdb5cc0ebadcd36d6f71380aa932efec3 (patch)
tree545ae58f8099fc490ecc48c05ba92f8a5514d4b6 /recipes-core/cacao/files
parent14d6ad1608c66b8970d4052dce4cd1fc64fb6ea2 (diff)
downloadmeta-java-b229a38bdb5cc0ebadcd36d6f71380aa932efec3.tar.gz
cacao-initial: add cacao-initial recipe from oe-classic
Diffstat (limited to 'recipes-core/cacao/files')
-rw-r--r--recipes-core/cacao/files/cacao-0.98-initial.patch45
-rw-r--r--recipes-core/cacao/files/disable_hw_exceptions.patch22
2 files changed, 67 insertions, 0 deletions
diff --git a/recipes-core/cacao/files/cacao-0.98-initial.patch b/recipes-core/cacao/files/cacao-0.98-initial.patch
new file mode 100644
index 0000000..30b6d14
--- /dev/null
+++ b/recipes-core/cacao/files/cacao-0.98-initial.patch
@@ -0,0 +1,45 @@
1Index: cacao-0.98/configure.ac
2===================================================================
3--- cacao-0.98.orig/configure.ac 2007-12-19 22:07:55.000000000 +0100
4+++ cacao-0.98/configure.ac 2007-12-19 22:08:02.000000000 +0100
5@@ -27,7 +27,7 @@
6 dnl Process this file with autoconf to produce a configure script.
7
8
9-AC_INIT(cacao, 0.98, cacao@cacaojvm.org)
10+AC_INIT(cacao-initial, 0.98, cacao@cacaojvm.org)
11 AC_CONFIG_SRCDIR(src/cacao/cacao.c)
12 AC_CANONICAL_HOST
13 AC_PREREQ(2.59)
14Index: cacao-0.98/src/vm/vm.c
15===================================================================
16--- cacao-0.98.orig/src/vm/vm.c 2007-12-19 22:31:19.000000000 +0100
17+++ cacao-0.98/src/vm/vm.c 2007-12-19 22:32:36.000000000 +0100
18@@ -623,7 +623,7 @@
19 #else
20 puts(" java.boot.class.path : "CLASSPATH_CLASSES"");
21 #endif
22- puts(" gnu.classpath.boot.library.path: "CLASSPATH_LIBDIR"/classpath\n");
23+ puts(" gnu.classpath.boot.library.path: "CLASSPATH_LIBDIR"/classpath-initial\n");
24
25 puts("Runtime variables:\n");
26 printf(" maximum heap size : %d\n", opt_heapmaxsize);
27@@ -828,15 +828,15 @@
28
29 /* and finally set the path to GNU Classpath libraries */
30
31- len = strlen(cacao_prefix) + strlen("/lib/classpath") + strlen("0");
32+ len = strlen(cacao_prefix) + strlen("/lib/classpath-initial") + strlen("0");
33
34 classpath_libdir = MNEW(char, len);
35 strcpy(classpath_libdir, cacao_prefix);
36- strcat(classpath_libdir, "/lib/classpath");
37+ strcat(classpath_libdir, "/lib/classpath-initial");
38 #else
39 cacao_prefix = CACAO_PREFIX;
40 cacao_libjvm = CACAO_LIBDIR"/libjvm";
41- classpath_libdir = CLASSPATH_LIBDIR"/classpath";
42+ classpath_libdir = CLASSPATH_LIBDIR"/classpath-initial";
43 #endif
44
45 /* set the bootclasspath */
diff --git a/recipes-core/cacao/files/disable_hw_exceptions.patch b/recipes-core/cacao/files/disable_hw_exceptions.patch
new file mode 100644
index 0000000..bf2e998
--- /dev/null
+++ b/recipes-core/cacao/files/disable_hw_exceptions.patch
@@ -0,0 +1,22 @@
1Index: cacao-0.98/src/vm/exceptions.c
2===================================================================
3--- cacao-0.98.orig/src/vm/exceptions.c 2007-06-05 09:41:07.000000000 +0200
4+++ cacao-0.98/src/vm/exceptions.c 2014-01-03 16:21:42.430783148 +0100
5@@ -89,17 +89,6 @@
6
7 bool exceptions_init(void)
8 {
9- int pagesize;
10-
11- /* mmap a memory page at address 0x0, so our hardware-exceptions
12- work. */
13-
14- pagesize = getpagesize();
15-
16- (void) memory_mmap_anon(NULL, pagesize, PROT_NONE, MAP_PRIVATE | MAP_FIXED);
17-
18- /* check if we get into trouble with our hardware-exceptions */
19-
20 if (OFFSET(java_bytearray, data) <= EXCEPTION_HARDWARE_PATCHER)
21 vm_abort("signal_init: array-data offset is less or equal the maximum hardware-exception displacement: %d <= %d", OFFSET(java_bytearray, data), EXCEPTION_HARDWARE_PATCHER);
22