summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/cacao-2d6f6c14daf9
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2019-06-18 17:09:04 +0200
committerRichard Leitner <richard.leitner@skidata.com>2019-06-25 13:10:34 +0200
commite3a04fb1ebe7d86cc2714667de587fbe6535ce63 (patch)
treecdbbd2f3511d249549d32c41e9f75883f6084bb8 /recipes-core/cacao/cacao-2d6f6c14daf9
parentd82f628867f493d9de9172217e26aec5d0ce6c68 (diff)
downloadmeta-java-e3a04fb1ebe7d86cc2714667de587fbe6535ce63.tar.gz
cacao: update to latest staging tip 2d6f6c14daf9
Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
Diffstat (limited to 'recipes-core/cacao/cacao-2d6f6c14daf9')
-rw-r--r--recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch41
-rw-r--r--recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch60
2 files changed, 101 insertions, 0 deletions
diff --git a/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch b/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch
new file mode 100644
index 0000000..2b046cf
--- /dev/null
+++ b/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch
@@ -0,0 +1,41 @@
1java.in: Do not use hardcode paths
2
3Cacao uses hardcoded paths to various files, if these paths are not
4provided. This causes issues when sharing sstate with otherwise
5identical workers, if build time paths are not identical.
6
7Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
8
9Upstream-Status: Inappropriate [Yocto-specific fixes]
10
11---
12 cacao-1.6.1/src/scripts/java.in | 16 ++++++++++++++--
13 1 file changed, 14 insertions(+), 2 deletions(-)
14
15diff --git cacao-1.6.1/src/scripts/java.in cacao-1.6.1/src/scripts/java.in
16index 0790f02..2118de7 100644
17--- cacao-1.6.1/src/scripts/java.in
18+++ cacao-1.6.1/src/scripts/java.in
19@@ -22,5 +22,17 @@
20 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
21 ## 02110-1301, USA.
22
23-IFS=""
24-exec $(dirname ${0})/cacao ${1+"$@"}
25+SH_DIR=`dirname "$0"`
26+CURRENT_DIR=`cd "${SH_DIR}" && pwd`
27+
28+# if this shell script is invoked through symlink, we get invalid paths. As getting the real path to this file is
29+# very painful using only /bin/sh, python is used instead.
30+PYTHON_STR="import os; print os.path.dirname(os.path.realpath(os.readlink(\"${CURRENT_DIR}/java\"))) if os.path.islink(\"${CURRENT_DIR}/java\") else \"${CURRENT_DIR}\""
31+REAL_DIR=`python -c "${PYTHON_STR}"`
32+
33+PARENT_DIR=`dirname ${REAL_DIR}`
34+
35+export BOOTCLASSPATH="${PARENT_DIR}/share/cacao/vm.zip:${PARENT_DIR}/share/classpath/glibj.zip"
36+LIBRARY_PATH="-Djava.library.path=${PARENT_DIR}/lib/classpath"
37+exec ${REAL_DIR}/cacao ${LIBRARY_PATH} ${1+"$@"}
38+
39--
402.7.4
41
diff --git a/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch b/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch
new file mode 100644
index 0000000..c30f5be
--- /dev/null
+++ b/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch
@@ -0,0 +1,60 @@
1cacao: use system's boehm garbage collector
2
3This is a Gentoo's patch [1] to force the use of system's bdwgc.
4
5Cacao was installing an internal version of bdwgc which conflicts
6with the system's version.
7
8[1] https://gitweb.gentoo.org/proj/java.git/plain/dev-java/cacao/files/system-boehm-gc.patch
9
10Upstream-Status: Inappropriate [not author]
11
12Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
13
14diff --git a/configure.ac b/configure.ac
15--- a/configure.ac
16+++ b/configure.ac
17@@ -691,6 +691,8 @@
18
19 AC_CHECK_ENABLE_PIC_ASM
20
21+PKG_CHECK_MODULES([BOEHM], bdw-gc,,AC_MSG_ERROR[boehm-gc not found])
22+
23 dnl Define version numbers.
24 AC_VERSION_DETAIL
25 AC_VERSION_CONFIG
26@@ -793,12 +795,6 @@
27 )
28
29
30-dnl We only build the shared library objects but we use it as
31-dnl noinst_LTLIBRARIES.
32-ac_configure_args="$ac_configure_args --disable-static"
33-AC_CONFIG_SUBDIRS(src/mm/boehm-gc)
34-
35-
36 AC_OUTPUT
37
38
39diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
40--- a/src/mm/Makefile.am
41+++ b/src/mm/Makefile.am
42@@ -35,14 +35,13 @@
43 endif
44
45 if ENABLE_GC_BOEHM
46-SUBDIRS = \
47- boehm-gc
48-
49 GC_FILE = \
50 gc-boehm.cpp
51
52-GC_LIB = \
53- $(top_builddir)/src/mm/boehm-gc/libgc.la
54+AM_CPPFLAGS += $(BOEHM_CFLAGS)
55+
56+GC_LIB = $(BOEHM_LIBS)
57+
58 endif
59
60 if ENABLE_GC_CACAO