summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/cacao-1.6.1
diff options
context:
space:
mode:
authorHugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>2015-03-31 13:39:59 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-31 13:48:09 -0300
commit6d8dc1af442559380b2e247984961ba6609b6052 (patch)
tree8980fd07a7c82c4c4da6056e4ac52893d26ed4b9 /recipes-core/cacao/cacao-1.6.1
parent458f78f923d0a8bbfb4e2b98c708a3d9acd70949 (diff)
downloadmeta-java-6d8dc1af442559380b2e247984961ba6609b6052.tar.gz
cacao: fix problem with internal garbage collector
Cacao uses an internal version of bdwgc that was being installed (headers, libs, etc.) together with the JVM, unnecessarily conflicting with original bdwgc package. A patch from Gentoo is applied so the system's bdwgc is used instead. Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/cacao/cacao-1.6.1')
-rw-r--r--recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch b/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch
new file mode 100644
index 0000000..c30f5be
--- /dev/null
+++ b/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch
@@ -0,0 +1,60 @@
1cacao: use system's boehm garbage collector
2
3This is a Gentoo's patch [1] to force the use of system's bdwgc.
4
5Cacao was installing an internal version of bdwgc which conflicts
6with the system's version.
7
8[1] https://gitweb.gentoo.org/proj/java.git/plain/dev-java/cacao/files/system-boehm-gc.patch
9
10Upstream-Status: Inappropriate [not author]
11
12Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
13
14diff --git a/configure.ac b/configure.ac
15--- a/configure.ac
16+++ b/configure.ac
17@@ -691,6 +691,8 @@
18
19 AC_CHECK_ENABLE_PIC_ASM
20
21+PKG_CHECK_MODULES([BOEHM], bdw-gc,,AC_MSG_ERROR[boehm-gc not found])
22+
23 dnl Define version numbers.
24 AC_VERSION_DETAIL
25 AC_VERSION_CONFIG
26@@ -793,12 +795,6 @@
27 )
28
29
30-dnl We only build the shared library objects but we use it as
31-dnl noinst_LTLIBRARIES.
32-ac_configure_args="$ac_configure_args --disable-static"
33-AC_CONFIG_SUBDIRS(src/mm/boehm-gc)
34-
35-
36 AC_OUTPUT
37
38
39diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
40--- a/src/mm/Makefile.am
41+++ b/src/mm/Makefile.am
42@@ -35,14 +35,13 @@
43 endif
44
45 if ENABLE_GC_BOEHM
46-SUBDIRS = \
47- boehm-gc
48-
49 GC_FILE = \
50 gc-boehm.cpp
51
52-GC_LIB = \
53- $(top_builddir)/src/mm/boehm-gc/libgc.la
54+AM_CPPFLAGS += $(BOEHM_CFLAGS)
55+
56+GC_LIB = $(BOEHM_LIBS)
57+
58 endif
59
60 if ENABLE_GC_CACAO