diff options
author | Tim Orling <tim.orling@konsulko.com> | 2024-02-02 13:45:12 -0800 |
---|---|---|
committer | Tim Orling <TicoTimo@gmail.com> | 2024-02-03 15:56:52 -0800 |
commit | c799db95582750b978111c86fd4a5f87e96de1b0 (patch) | |
tree | 1adcd4475c87e7cf060eb691e10d40dc824b74f2 | |
parent | 8c0c9f13cb89008f080fded0ca435f388e97bd7b (diff) | |
download | meta-java-c799db95582750b978111c86fd4a5f87e96de1b0.tar.gz |
jsch,xerces-j: fix deprecated CVE_CHECK_IGNORE
The preferred variable name is now CVE_STATUS since:
openembedded-core 34f682a24b7075b12ec308154b937ad118d69fe5
"cve-check: add option to add additional patched CVEs"
Fixes:
WARNING: /build/../meta-java/recipes-core/jcraft/jsch_0.1.40.bb:
CVE_CHECK_IGNORE is deprecated in favor of CVE_STATUS
WARNING: /build/../meta-java/recipes-core/xerces-j/xerces-j_2.11.0.bb:
CVE_CHECK_IGNORE is deprecated in favor of CVE_STATUS
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r-- | recipes-core/jcraft/jsch_0.1.40.bb | 2 | ||||
-rw-r--r-- | recipes-core/xerces-j/xerces-j_2.11.0.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/jcraft/jsch_0.1.40.bb b/recipes-core/jcraft/jsch_0.1.40.bb index 2597126..8ef5c85 100644 --- a/recipes-core/jcraft/jsch_0.1.40.bb +++ b/recipes-core/jcraft/jsch_0.1.40.bb | |||
@@ -26,7 +26,7 @@ SRC_URI[md5sum] = "b59cec19a487e95aed68378976b4b566" | |||
26 | SRC_URI[sha256sum] = "ca9d2ae08fd7a8983fb00d04f0f0c216a985218a5eb364ff9bee73870f28e097" | 26 | SRC_URI[sha256sum] = "ca9d2ae08fd7a8983fb00d04f0f0c216a985218a5eb364ff9bee73870f28e097" |
27 | 27 | ||
28 | # Ignore the CVE because it only affects Windows platforms | 28 | # Ignore the CVE because it only affects Windows platforms |
29 | CVE_CHECK_IGNORE += "CVE-2016-5725" | 29 | CVE_STATUS += "CVE-2016-5725" |
30 | 30 | ||
31 | BBCLASSEXTEND = "native" | 31 | BBCLASSEXTEND = "native" |
32 | 32 | ||
diff --git a/recipes-core/xerces-j/xerces-j_2.11.0.bb b/recipes-core/xerces-j/xerces-j_2.11.0.bb index dcdd510..c7a54ab 100644 --- a/recipes-core/xerces-j/xerces-j_2.11.0.bb +++ b/recipes-core/xerces-j/xerces-j_2.11.0.bb | |||
@@ -18,7 +18,7 @@ SRC_URI = "http://archive.apache.org/dist/xerces/j/source/Xerces-J-src.${PV}.tar | |||
18 | # Already fixed with updates and closed. | 18 | # Already fixed with updates and closed. |
19 | # https://access.redhat.com/security/cve/CVE-2018-2799 | 19 | # https://access.redhat.com/security/cve/CVE-2018-2799 |
20 | # https://bugzilla.redhat.com/show_bug.cgi?id=1567542 | 20 | # https://bugzilla.redhat.com/show_bug.cgi?id=1567542 |
21 | CVE_CHECK_IGNORE += "CVE-2018-2799" | 21 | CVE_STATUS += "CVE-2018-2799" |
22 | 22 | ||
23 | S = "${WORKDIR}/xerces-2_11_0" | 23 | S = "${WORKDIR}/xerces-2_11_0" |
24 | 24 | ||