summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAJ Bagwell <anthony.bagwell@hivehome.com>2021-08-09 14:09:38 +0100
committerRichard Leitner <richard.leitner@skidata.com>2021-08-11 07:19:38 +0200
commita1eb2b9788ed48508bbe87acf0fd9269aa3585f4 (patch)
treeee6a6f1ff9ea93c9a87f0b5d20577655eca5bfe9
parentb71a9866abfd5292650ef0afc5ecb9ab5e29b887 (diff)
downloadmeta-java-a1eb2b9788ed48508bbe87acf0fd9269aa3585f4.tar.gz
all: manual fixes for new override syntax
Signed-off-by: AJ Bagwell <anthony.bagwell@hivehome.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--classes/java-library.bbclass4
-rw-r--r--recipes-core/ant/ant-native_1.8.1.bb4
-rw-r--r--recipes-core/junit/junit_3.8.2.bb4
-rw-r--r--recipes-core/openjdk/openjdk-8-release-common.inc3
-rw-r--r--recipes-core/xml-commons/xom_1.2.10.bb2
5 files changed, 9 insertions, 8 deletions
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index 62fabec..67541d2 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -54,14 +54,14 @@ ALTJARFILENAMES = "${BPN}.jar"
54 54
55# Java "source" distributions often contain precompiled things 55# Java "source" distributions often contain precompiled things
56# we want to delete first. 56# we want to delete first.
57do:removebinaries() { 57do_deletebinaries() {
58 find ${WORKDIR} ! -path "${RECIPE_SYSROOT}/*" ! -path "${RECIPE_SYSROOT_NATIVE}/*" \ 58 find ${WORKDIR} ! -path "${RECIPE_SYSROOT}/*" ! -path "${RECIPE_SYSROOT_NATIVE}/*" \
59 -name "*.jar" -exec rm {} \; 59 -name "*.jar" -exec rm {} \;
60 find ${WORKDIR} ! -path "${RECIPE_SYSROOT}/*" ! -path "${RECIPE_SYSROOT_NATIVE}/*" \ 60 find ${WORKDIR} ! -path "${RECIPE_SYSROOT}/*" ! -path "${RECIPE_SYSROOT_NATIVE}/*" \
61 -name "*.class" -exec rm {} \; 61 -name "*.class" -exec rm {} \;
62} 62}
63 63
64addtask removebinaries after do_unpack before do_patch 64addtask deletebinaries after do_unpack before do_patch
65 65
66do_install:append() { 66do_install:append() {
67 oe_jarinstall ${JARFILENAME} ${ALTJARFILENAMES} 67 oe_jarinstall ${JARFILENAME} ${ALTJARFILENAMES}
diff --git a/recipes-core/ant/ant-native_1.8.1.bb b/recipes-core/ant/ant-native_1.8.1.bb
index fa37dd1..8814039 100644
--- a/recipes-core/ant/ant-native_1.8.1.bb
+++ b/recipes-core/ant/ant-native_1.8.1.bb
@@ -20,7 +20,7 @@ DEPENDS = " \
20 junit-native jdepend-native commons-net-native commons-logging-native \ 20 junit-native jdepend-native commons-net-native commons-logging-native \
21 " 21 "
22 22
23do:removecruft() { 23do_deletecruft() {
24 # Removes thing that need proprietary Jar files or are otherwise problematic 24 # Removes thing that need proprietary Jar files or are otherwise problematic
25 rm -rf ${S}/src/main/org/apache/tools/ant/taskdefs/optional/image 25 rm -rf ${S}/src/main/org/apache/tools/ant/taskdefs/optional/image
26 rm -rf ${S}/src/main/org/apache/tools/ant/types/optional/image 26 rm -rf ${S}/src/main/org/apache/tools/ant/types/optional/image
@@ -30,7 +30,7 @@ do:removecruft() {
30 rm -rf ${S}/src/main/org/apache/tools/ant/taskdefs/optional/NetRexxC.java 30 rm -rf ${S}/src/main/org/apache/tools/ant/taskdefs/optional/NetRexxC.java
31} 31}
32 32
33addtask removecruft before do_patch after do:removebinaries 33addtask deletecruft before do_patch after do_deletebinaries
34 34
35do_compile() { 35do_compile() {
36 mkdir -p build 36 mkdir -p build
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
index 4f10575..feaddc3 100644
--- a/recipes-core/junit/junit_3.8.2.bb
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -16,14 +16,14 @@ inherit java-library
16do_unpackpost[dirs] = "${B}" 16do_unpackpost[dirs] = "${B}"
17do_unpackpost() { 17do_unpackpost() {
18 mkdir -p src 18 mkdir -p src
19 # Prevent deletion by do:removebinaries. 19 # Prevent deletion by do_deletebinraries.
20 if [ -e src.jar ]; then 20 if [ -e src.jar ]; then
21 mv src.jar src.zip 21 mv src.jar src.zip
22 fi 22 fi
23 unzip -o src.zip -d src 23 unzip -o src.zip -d src
24} 24}
25 25
26addtask unpackpost before do:removebinaries after do_unpack 26addtask unpackpost before do_deletebinraries after do_unpack
27 27
28do_compile() { 28do_compile() {
29 mkdir -p build 29 mkdir -p build
diff --git a/recipes-core/openjdk/openjdk-8-release-common.inc b/recipes-core/openjdk/openjdk-8-release-common.inc
index 6c7bdd2..ff8d96e 100644
--- a/recipes-core/openjdk/openjdk-8-release-common.inc
+++ b/recipes-core/openjdk/openjdk-8-release-common.inc
@@ -1,3 +1,4 @@
1
1PATCHES_URI = "\ 2PATCHES_URI = "\
2 file://0001-Allow-using-a-system-installed-libjpeg.patch \ 3 file://0001-Allow-using-a-system-installed-libjpeg.patch \
3 file://0002-Allow-using-a-system-installed-libpng.patch \ 4 file://0002-Allow-using-a-system-installed-libpng.patch \
@@ -56,7 +57,7 @@ PATCHES_URI:append:libc-musl = "\
56 ${DISABLE_AGENT_BUILD_PT2} \ 57 ${DISABLE_AGENT_BUILD_PT2} \
57 file://musl-0006-hotspot-os_linux-remove-glibc-dependencies-common.patch \ 58 file://musl-0006-hotspot-os_linux-remove-glibc-dependencies-common.patch \
58 ${REMOVE_GLIBC_DEPENDENCIES_PT2} \ 59 ${REMOVE_GLIBC_DEPENDENCIES_PT2} \
59 file://musl-0007-hotspot-os_linux:x86-remove-glibc-dependencies-fpu_c.patch \ 60 file://musl-0007-hotspot-os_linux_x86-remove-glibc-dependencies-fpu_c.patch \
60 file://musl-0008-jdk-musl-build-fix-use-SIGRTMAX-rather-than-__SIGRTM.patch \ 61 file://musl-0008-jdk-musl-build-fix-use-SIGRTMAX-rather-than-__SIGRTM.patch \
61 file://musl-0009-jdk-musl-has-gethostby_r.patch \ 62 file://musl-0009-jdk-musl-has-gethostby_r.patch \
62" 63"
diff --git a/recipes-core/xml-commons/xom_1.2.10.bb b/recipes-core/xml-commons/xom_1.2.10.bb
index 5a71655..2520405 100644
--- a/recipes-core/xml-commons/xom_1.2.10.bb
+++ b/recipes-core/xml-commons/xom_1.2.10.bb
@@ -36,7 +36,7 @@ do_move_jaxen() {
36 36
37} 37}
38 38
39addtask move_jaxen after do:removebinaries before do_patch 39addtask move_jaxen after do_deletebinraries before do_patch
40 40
41do_compile() { 41do_compile() {
42 mkdir -p build 42 mkdir -p build