summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFang Jia <fang.jia@windriver.com>2019-02-21 11:23:07 +0800
committerRichard Leitner <richard.leitner@skidata.com>2019-07-19 10:01:43 +0200
commita03d3129c2d2463548d7696041a597cd601b9eec (patch)
tree15636b0175d16ce82cb9b7be37f88f97f8899e96
parente8cd0b623407d52cdb9ea1a46b29723645cb2883 (diff)
downloadmeta-java-a03d3129c2d2463548d7696041a597cd601b9eec.tar.gz
Revert "base-files: Define JAVA_HOME by default"
This reverts commit ada652564f09756a81f54495cbc2091125239625. When enable multilib on a 64-bit system, probably both base-file and lib32-base-files are installed. Then both packages want to modify the file "profile", there will be an error like: " Error: Transaction check error: file /etc/profile conflicts between attempted installs of lib32-base-files-3.0.14-r148.gpb_virt and base-files-3.0.14-r148.gpb_virt " The task can be added by adding a file to ${sysconfdir}/profile.d/. Signed-off-by: Fang Jia <fang.jia@windriver.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend13
1 files changed, 0 insertions, 13 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
deleted file mode 100644
index 4651185..0000000
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
1do_install_append() {
2 cat >> ${D}${sysconfdir}/profile << EOT
3JAVA_HOME=""
4for dir in ${libdir}/jvm/*; do
5 if [ -x "\${dir}/bin/java" ]; then
6 [ -z "\${JAVA_HOME}" ] && JAVA_HOME="\${dir}"
7 fi
8done
9if [ -n "\${JAVA_HOME}" ]; then
10 export JAVA_HOME=\${JAVA_HOME}
11fi
12EOT
13}