summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/isa-l/isa-l_2.31.0.bb (renamed from recipes-support/isa-l/isa-l_2.28.0.bb)8
-rw-r--r--recipes-support/jhi/jhi_1.33.bb66
-rw-r--r--recipes-support/libipt/libipt_2.1.1.bb (renamed from recipes-support/libipt/libipt_2.0.1.bb)14
-rw-r--r--recipes-support/sbsigntool/sbsigntool-native_git.bb19
-rw-r--r--recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch2
5 files changed, 25 insertions, 84 deletions
diff --git a/recipes-support/isa-l/isa-l_2.28.0.bb b/recipes-support/isa-l/isa-l_2.31.0.bb
index 98f0d311..d5d09002 100644
--- a/recipes-support/isa-l/isa-l_2.28.0.bb
+++ b/recipes-support/isa-l/isa-l_2.31.0.bb
@@ -2,16 +2,18 @@ SUMMARY = "Intelligent Storage Acceleration Library"
2DESCRIPTION = "ISA-L is a collection of optimized low-level functions \ 2DESCRIPTION = "ISA-L is a collection of optimized low-level functions \
3targeting storage applications." 3targeting storage applications."
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e6c7d82ad7dd512687b0991a159a1ca9" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=2476688d0948d4a3f7c69473a603540d"
6SECTION = "lib" 6SECTION = "lib"
7 7
8inherit autotools pkgconfig 8inherit autotools pkgconfig
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11SRCREV = "fae4c3a4994f894bf57adafa18ed310d145ab1b0" 11SRCREV = "bd226375027899087bd48f3e59b910430615cc0a"
12SRC_URI = "git://github.com/intel/isa-l.git" 12SRC_URI = "git://github.com/intel/isa-l.git;branch=master;protocol=https"
13 13
14DEPENDS = "nasm-native" 14DEPENDS = "nasm-native"
15AS[unexport] = "1" 15AS[unexport] = "1"
16 16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
17COMPATIBLE_HOST = '(x86_64).*-linux' 19COMPATIBLE_HOST = '(x86_64).*-linux'
diff --git a/recipes-support/jhi/jhi_1.33.bb b/recipes-support/jhi/jhi_1.33.bb
deleted file mode 100644
index c52af957..00000000
--- a/recipes-support/jhi/jhi_1.33.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1SUMMARY = "Intel Dynamic Application Loader (DAL) Host Interface"
2DESCRIPTION = "A daemon and libraries which allow user space applications \
3to install Java applets on DAL FW and communicate with them"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=833126f14614a3276708a4d7c9734645"
6
7SRC_URI = "git://github.com/intel/dynamic-application-loader-host-interface.git;protocol=https"
8
9inherit cmake useradd systemd pkgconfig
10
11SRCREV = "44d64cdbcf7eacd397ce9c18b9094514b62093e6"
12
13S = "${WORKDIR}/git"
14
15DEPENDS += "util-linux libxml2"
16DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
17RDEPENDS_${PN} += "bash"
18
19USERADD_PACKAGES = "${PN}"
20USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false -g mei jhi"
21
22GROUPADD_PARAM_${PN} = "-g 880 mei"
23
24SYSTEMD_PACKAGES = "${PN}"
25
26COMPATIBLE_HOST_libc-musl = 'null'
27
28# systemd is the default so they are installed when sysvinit is not selected as INIT_SYSTEM
29EXTRA_OECMAKE = "-DCMAKE_SKIP_RPATH=ON \
30 -DINIT_SYSTEM=${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'SysVinit', 'systemd', d)} \
31 -DAPPLETS_DIR=${libdir}/dal/applets \
32 -DAPP_REPO_DIR=${localstatedir}/cache/dal/applet_repository \
33 "
34
35do_install_append () {
36 install -d ${D}${localstatedir}/cache/dal/applet_repository
37
38 chown -R jhi ${D}${localstatedir}/cache/dal/applet_repository
39 chgrp -R mei ${D}${localstatedir}/cache/dal/applet_repository
40
41 install -d ${D}${bindir}
42 install -m 755 ${B}/bin_linux/smoketest ${D}${bindir}
43 install -m 755 ${B}/bin_linux/bist ${D}${bindir}
44
45 install -d ${D}${libdir}/dal/applets
46 cp -r ${S}/test/smoketest/applets/* ${D}${libdir}/dal/applets/
47}
48
49PACKAGES =+ "${PN}-test"
50
51FILES_${PN}-dev = ""
52
53FILES_${PN} = "\
54 ${sbindir} \
55 ${sysconfdir} \
56 ${libdir} \
57 ${libdir}/dal/applets \
58 ${nonarch_libdir}/tmpfiles.d \
59 ${systemd_system_unitdir} \
60 ${localstatedir}/cache/dal/applet_repository \
61 "
62
63FILES_${PN}-test = "\
64 ${bindir} \
65 ${libdir}/dal/applets \
66 "
diff --git a/recipes-support/libipt/libipt_2.0.1.bb b/recipes-support/libipt/libipt_2.1.1.bb
index 68f6d5c5..c4b5ecaa 100644
--- a/recipes-support/libipt/libipt_2.0.1.bb
+++ b/recipes-support/libipt/libipt_2.1.1.bb
@@ -5,28 +5,30 @@ library or it can be partially or fully integrated into your tool."
5HOMEPAGE = "https://github.com/intel/libipt" 5HOMEPAGE = "https://github.com/intel/libipt"
6 6
7LICENSE = "BSD-3-Clause" 7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c91702d8338efc75588b838922b7b803" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=a429afa59f273b5d12778eda69d10313"
9 9
10inherit pkgconfig cmake 10inherit pkgconfig cmake
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14SRC_URI = "git://github.com/intel/libipt.git;protocol=https;branch=stable/v2.0" 14SRC_URI = "git://github.com/intel/libipt.git;protocol=https;branch=stable/v2.1"
15 15
16SRCREV = "916d777123bf60d323890557347570e5e19dfa12" 16SRCREV = "1c9bc700f4b9a71fd2d1cf1742de7e2351ddb281"
17 17
18EXTRA_OECMAKE += " \ 18EXTRA_OECMAKE += " \
19 -DPTDUMP=ON \ 19 -DPTDUMP=ON \
20 -DPTTC=ON \ 20 -DPTTC=ON \
21 -DPTSEG=ON \
22 -DCMAKE_SKIP_RPATH=ON \
21 " 23 "
22 24
23do_install_append() { 25do_install:append() {
24 install -d ${D}${bindir}/libipt 26 install -d ${D}${bindir}/libipt
25 install -d ${D}${bindir}/libipt/tests 27 install -d ${D}${bindir}/libipt/tests
26 28
27 cp -r ${B}/bin/* ${D}${bindir}/libipt/ 29 cp -r ${B}/bin/* ${D}${bindir}/libipt/
28 cp -r ${WORKDIR}/git/test/src/* ${D}${bindir}/libipt/tests 30 cp -r ${S}/test/src/* ${D}${bindir}/libipt/tests
29} 31}
30 32
31FILES_${PN}-test = "${bindir}" 33FILES:${PN}-test = "${bindir}"
32PACKAGES =+ "${PN}-test" 34PACKAGES =+ "${PN}-test"
diff --git a/recipes-support/sbsigntool/sbsigntool-native_git.bb b/recipes-support/sbsigntool/sbsigntool-native_git.bb
index 8b42e05b..5a9f5b4d 100644
--- a/recipes-support/sbsigntool/sbsigntool-native_git.bb
+++ b/recipes-support/sbsigntool/sbsigntool-native_git.bb
@@ -1,5 +1,5 @@
1DESCRIPTION = "Utility for signing and verifying files for UEFI Secure Boot" 1DESCRIPTION = "Utility for signing and verifying files for UEFI Secure Boot"
2LICENSE = "GPLv3 & LGPL-2.1 & LGPL-3.0 & MIT" 2LICENSE = "GPL-3.0-only & LGPL-2.1-only & LGPL-3.0-only & MIT"
3 3
4# sbsigntool statically links to libccan.a which is built with modules 4# sbsigntool statically links to libccan.a which is built with modules
5# passed to "create-ccan-tree" (and their dependencies). Therefore, 5# passed to "create-ccan-tree" (and their dependencies). Therefore,
@@ -19,24 +19,25 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=9eef91148a9b14ec7f9df333daebc746 \
19 19
20# The original upstream is git://kernel.ubuntu.com/jk/sbsigntool but it has 20# The original upstream is git://kernel.ubuntu.com/jk/sbsigntool but it has
21# not been maintained and many patches have been backported in this repo. 21# not been maintained and many patches have been backported in this repo.
22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools \ 22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools;branch=master \
23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan \ 23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan;branch=master \
24 file://0001-configure-Fixup-build-dependencies-for-cross-compili.patch \ 24 file://0001-configure-Fixup-build-dependencies-for-cross-compili.patch \
25 " 25 "
26 26
27SRCREV_sbsigntools ?= "fe88da5f66241d959b7aeca7502d401ad88df410" 27SRCREV_sbsigntools ?= "9cfca9fe7aa7a8e29b92fe33ce8433e212c9a8ba"
28SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5" 28SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5"
29SRCREV_FORMAT = "sbsigntools_ccan" 29SRCREV_FORMAT = "sbsigntools_ccan"
30 30
31DEPENDS = "binutils-native gnu-efi-native help2man-native openssl-native util-linux-native" 31DEPENDS = "binutils-native gnu-efi-native help2man-native openssl-native util-linux-native"
32 32
33PV = "0.9.3-git${SRCPV}" 33PV = "0.9.5"
34 34
35S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
36 36
37inherit native autotools pkgconfig 37inherit autotools pkgconfig
38inherit native
38 39
39do_configure_prepend() { 40do_configure:prepend() {
40 cd ${S} 41 cd ${S}
41 42
42 sed -i s#RECIPE_SYSROOT#${RECIPE_SYSROOT_NATIVE}#g configure.ac 43 sed -i s#RECIPE_SYSROOT#${RECIPE_SYSROOT_NATIVE}#g configure.ac
@@ -78,3 +79,5 @@ EXTRA_OEMAKE = "\
78 -I${STAGING_INCDIR_NATIVE} \ 79 -I${STAGING_INCDIR_NATIVE} \
79 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \ 80 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \
80 " 81 "
82
83CFLAGS:append = " -Wno-error"
diff --git a/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch b/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch
index ef686511..ea7bee29 100644
--- a/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch
+++ b/recipes-support/sbsigntool/sbsigntool/0001-configure-Fixup-build-dependencies-for-cross-compili.patch
@@ -10,7 +10,7 @@ under /usr/include and /usr/lib.
10Prepend these paths with a placeholder that can be replaced with the 10Prepend these paths with a placeholder that can be replaced with the
11actual paths once they are resolved. 11actual paths once they are resolved.
12 12
13Upstream status: inappropriate [OE specific] 13Upstream-Status: Inappropriate [OE specific]
14 14
15Signed-off-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com> 15Signed-off-by: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
16 16