summaryrefslogtreecommitdiffstats
path: root/recipes-rt/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-rt/images')
-rw-r--r--recipes-rt/images/core-image-rt-sdk.bb20
-rw-r--r--recipes-rt/images/core-image-rt.bb17
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-rt/images/core-image-rt-sdk.bb b/recipes-rt/images/core-image-rt-sdk.bb
new file mode 100644
index 00000000..6b43a872
--- /dev/null
+++ b/recipes-rt/images/core-image-rt-sdk.bb
@@ -0,0 +1,20 @@
1require recipes-core/images/core-image-minimal.bb
2
3# Skip processing of this recipe if linux-intel-rt is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers.
6python () {
7 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
8 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
9}
10
11DESCRIPTION = "Small image capable of booting a device with a test suite and \
12tools for real-time use. It includes the full meta-toolchain, development \
13headers and libraries to form a standalone SDK."
14DEPENDS = "linux-intel-rt"
15
16IMAGE_FEATURES += "dev-pkgs tools-sdk tools-debug eclipse-debug tools-profile tools-testapps debug-tweaks"
17
18IMAGE_INSTALL += "rt-tests hwlatdetect kernel-dev"
19
20LICENSE = "MIT"
diff --git a/recipes-rt/images/core-image-rt.bb b/recipes-rt/images/core-image-rt.bb
new file mode 100644
index 00000000..4db0a579
--- /dev/null
+++ b/recipes-rt/images/core-image-rt.bb
@@ -0,0 +1,17 @@
1require recipes-core/images/core-image-minimal.bb
2
3# Skip processing of this recipe if linux-intel-rt is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers.
6python () {
7 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
8 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
9}
10
11DESCRIPTION = "A small image just capable of allowing a device to boot plus a \
12real-time test suite and tools appropriate for real-time use."
13DEPENDS = "linux-intel-rt"
14
15IMAGE_INSTALL += "rt-tests hwlatdetect"
16
17LICENSE = "MIT"