summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-oneapi')
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch42
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb_2021.11.1.bb (renamed from recipes-oneapi/crypto/intel-crypto-mb_2021.6.bb)14
-rw-r--r--recipes-oneapi/onedpl/onedpl_2022.3.0.bb (renamed from recipes-oneapi/onedpl/onedpl_2021.7.0.bb)6
-rw-r--r--recipes-oneapi/setup-oneapi-env/setup-intel-oneapi-env_2023.0.0-25370.bb (renamed from recipes-oneapi/setup-oneapi-env/setup-intel-oneapi-env_2022.0.1-3633.bb)5
4 files changed, 57 insertions, 10 deletions
diff --git a/recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch b/recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch
new file mode 100644
index 00000000..c47c8de5
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch
@@ -0,0 +1,42 @@
1From 3b7b4eca54aa8d851e37f60c74e4a027fa7b21f2 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 14 Jun 2023 13:18:45 +0800
4Subject: [PATCH] crypto-mb: Make sure libs are installed correctly
5
6Dont assume that "lib" is always the correct destination. This fixes
7multilib builds when libdir != /usr/lib.
8
9Upstream-Status: Pending
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 sources/ippcp/crypto_mb/src/CMakeLists.txt | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/sources/ippcp/crypto_mb/src/CMakeLists.txt b/sources/ippcp/crypto_mb/src/CMakeLists.txt
17index c9cad06..31f52bd 100644
18--- a/sources/ippcp/crypto_mb/src/CMakeLists.txt
19+++ b/sources/ippcp/crypto_mb/src/CMakeLists.txt
20@@ -123,8 +123,8 @@ endif(DYNAMIC_LIB OR MB_STANDALONE)
21 # Installation of the shared library
22 if (MB_STANDALONE) # standalone crypto_mb's cmake run
23 install(TARGETS ${MB_DYN_LIB_TARGET}
24- LIBRARY DESTINATION "lib"
25- RUNTIME DESTINATION "lib"
26+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
27+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}
28 PUBLIC_HEADER DESTINATION "include/crypto_mb")
29 elseif (DYNAMIC_LIB) # build from ippcp's cmake
30 install(TARGETS ${MB_DYN_LIB_TARGET}
31@@ -154,7 +154,7 @@ endif()
32 # Static lib installation
33 if(MB_STANDALONE)
34 install(TARGETS ${MB_STATIC_LIB_TARGET}
35- ARCHIVE DESTINATION "lib"
36+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
37 PUBLIC_HEADER DESTINATION "include/crypto_mb")
38 else()
39 install(TARGETS ${MB_STATIC_LIB_TARGET}
40--
412.37.3
42
diff --git a/recipes-oneapi/crypto/intel-crypto-mb_2021.6.bb b/recipes-oneapi/crypto/intel-crypto-mb_2021.11.1.bb
index 960aa17c..be72fd85 100644
--- a/recipes-oneapi/crypto/intel-crypto-mb_2021.6.bb
+++ b/recipes-oneapi/crypto/intel-crypto-mb_2021.11.1.bb
@@ -8,12 +8,14 @@ LICENSE = "Apache-2.0"
8 8
9LIC_FILES_CHKSUM = "file://../../../LICENSE;md5=e787af283468feca985d6b865d27d95b" 9LIC_FILES_CHKSUM = "file://../../../LICENSE;md5=e787af283468feca985d6b865d27d95b"
10 10
11SRC_URI = " \ 11IPP_BRANCH = "ipp-crypto_${@'_'.join(d.getVar('PV').rsplit('.')[-3:])}"
12 git://github.com/intel/ipp-crypto;protocol=https;branch=develop \ 12
13 file://0001-CMakeLists.txt-exclude-host-system-headers.patch;striplevel=4 \ 13SRC_URI = "git://github.com/intel/ipp-crypto;protocol=https;branch=${IPP_BRANCH} \
14 file://0002-cmake-exclude-Yocto-build-flags.patch;striplevel=4 \ 14 file://0001-CMakeLists.txt-exclude-host-system-headers.patch;striplevel=4 \
15 " 15 file://0002-cmake-exclude-Yocto-build-flags.patch;striplevel=4 \
16SRCREV = "3ae57715fbc7383ef527cab0b824d736b60fa06d" 16 file://0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch;striplevel=4 \
17 "
18SRCREV = "d02611e34328898d16025467d3deeb7d62b6076b"
17 19
18S = "${WORKDIR}/git/sources/ippcp/crypto_mb" 20S = "${WORKDIR}/git/sources/ippcp/crypto_mb"
19 21
diff --git a/recipes-oneapi/onedpl/onedpl_2021.7.0.bb b/recipes-oneapi/onedpl/onedpl_2022.3.0.bb
index c3533823..d80b64c9 100644
--- a/recipes-oneapi/onedpl/onedpl_2021.7.0.bb
+++ b/recipes-oneapi/onedpl/onedpl_2022.3.0.bb
@@ -7,13 +7,13 @@ HOMEPAGE = "https://github.com/oneapi-src/oneDPL"
7 7
8LICENSE = "Apache-2.0-with-LLVM-exception" 8LICENSE = "Apache-2.0-with-LLVM-exception"
9LIC_FILES_CHKSUM = "file://licensing/LICENSE.txt;md5=2e982d844baa4df1c80de75470e0c5cb \ 9LIC_FILES_CHKSUM = "file://licensing/LICENSE.txt;md5=2e982d844baa4df1c80de75470e0c5cb \
10 file://licensing/third-party-programs.txt;md5=74cbe473c3521af32a92f662c44aa6bd" 10 file://licensing/third-party-programs.txt;md5=cfb8d6b1f04a8fcc7d0dddd817619634"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14SRC_URI = "git://github.com/oneapi-src/oneDPL.git;protocol=https;branch=release/2021.7 \ 14SRC_URI = "git://github.com/oneapi-src/oneDPL.git;protocol=https;branch=release/2022.3 \
15 " 15 "
16SRCREV = "df96969b76f075bd9ce14c303659595c747c7223" 16SRCREV = "180f18ad25fbc39fa13bad43f1df7d54ee8f5609"
17 17
18do_compile[noexec] = "1" 18do_compile[noexec] = "1"
19do_configure[noexec] = "1" 19do_configure[noexec] = "1"
diff --git a/recipes-oneapi/setup-oneapi-env/setup-intel-oneapi-env_2022.0.1-3633.bb b/recipes-oneapi/setup-oneapi-env/setup-intel-oneapi-env_2023.0.0-25370.bb
index 702f794e..a1762a16 100644
--- a/recipes-oneapi/setup-oneapi-env/setup-intel-oneapi-env_2022.0.1-3633.bb
+++ b/recipes-oneapi/setup-oneapi-env/setup-intel-oneapi-env_2023.0.0-25370.bb
@@ -7,9 +7,12 @@ LIC_FILES_CHKSUM = "file://${CUSTOM_LICENSES_PATH}/EULA;md5=7bfc91523de2e84e7131
7 7
8SRC_URI = "file://intel-oneapi-runtime.conf" 8SRC_URI = "file://intel-oneapi-runtime.conf"
9 9
10S = "${WORKDIR}/sources"
11UNPACKDIR = "${S}"
12
10do_install() { 13do_install() {
11 mkdir -p ${D}${sysconfdir}/ld.so.conf.d/ 14 mkdir -p ${D}${sysconfdir}/ld.so.conf.d/
12 install -m 644 ${WORKDIR}/intel-oneapi-runtime.conf ${D}${sysconfdir}/ld.so.conf.d/ 15 install -m 644 ${S}/intel-oneapi-runtime.conf ${D}${sysconfdir}/ld.so.conf.d/
13} 16}
14 17
15pkg_postinst_ontarget:${PN}() { 18pkg_postinst_ontarget:${PN}() {