summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi/crypto/intel-crypto-mb_2021.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-oneapi/crypto/intel-crypto-mb_2021.8.bb')
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb_2021.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-oneapi/crypto/intel-crypto-mb_2021.8.bb b/recipes-oneapi/crypto/intel-crypto-mb_2021.8.bb
new file mode 100644
index 00000000..3ec038a6
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb_2021.8.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Crypto Multi-buffer Library"
2DESCRIPTION = "Intel® Integrated Performance Primitives (Intel® IPP) Cryptography \
3is a secure, fast and lightweight library of building blocks for cryptography, \
4highly-optimized for various Intel® CPUs."
5HOMEPAGE = "https://github.com/intel/ipp-crypto"
6
7LICENSE = "Apache-2.0"
8
9LIC_FILES_CHKSUM = "file://../../../LICENSE;md5=e787af283468feca985d6b865d27d95b"
10
11SRC_URI = " \
12 git://github.com/intel/ipp-crypto;protocol=https;branch=ipp-crypto_2021_8 \
13 file://0001-CMakeLists.txt-exclude-host-system-headers.patch;striplevel=4 \
14 file://0002-cmake-exclude-Yocto-build-flags.patch;striplevel=4 \
15 file://0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch;striplevel=4 \
16 "
17SRCREV = "97d2971a96bb7b956fcd8d974473895792fb5d49"
18
19S = "${WORKDIR}/git/sources/ippcp/crypto_mb"
20
21DEPENDS = "openssl"
22
23inherit cmake pkgconfig
24COMPATIBLE_HOST = '(x86_64).*-linux'
25
26EXTRA_OECMAKE += " -DARCH=intel64"
27EXTRA_OECMAKE += " -DTOOLCHAIN_OPTIONS='${TOOLCHAIN_OPTIONS}'"