summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/vpl/libvpl_2.10.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/vpl/libvpl_2.10.2.bb')
-rw-r--r--recipes-multimedia/vpl/libvpl_2.10.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-multimedia/vpl/libvpl_2.10.2.bb b/recipes-multimedia/vpl/libvpl_2.10.2.bb
new file mode 100644
index 00000000..04888e97
--- /dev/null
+++ b/recipes-multimedia/vpl/libvpl_2.10.2.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Intel Video Processing Library"
2DESCRIPTION = "Intel Video Processing Library (VPL) provides \
3a single video processing API for encode, decode, and video processing \
4that works across a wide range of accelerators."
5
6HOMEPAGE = "https://github.com/intel/libvpl"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c18ea6bb4786a26bf4eee88a7424a408 \
9 file://third-party-programs.txt;md5=ddf05049184e74942f45b0ca4cc69b8a"
10
11SRC_URI = "git://github.com/intel/libvpl.git;protocol=https;branch=main \
12 file://0001-vpl.pc.in-dont-pass-pcfiledir-to-cflags.patch \
13 "
14SRCREV = "383b5caac6df614e76ade5a07c4f53be702e9176"
15S = "${WORKDIR}/git"
16
17inherit cmake
18DEPENDS += "libva pkgconfig-native"
19
20PACKAGECONFIG ??= "tools"
21PACKAGECONFIG[tools] = "-DBUILD_TOOLS=ON, -DBUILD_TOOLS=OFF, wayland wayland-native wayland-protocols"
22
23do_install:append() {
24 mkdir -p ${D}${datadir}/VPL/samples
25 mv ${D}${bindir}/sample_* ${D}${datadir}/VPL/samples
26}
27
28COMPATIBLE_HOST = '(x86_64).*-linux'
29
30PACKAGES =+ "${PN}-examples"
31
32RREPLACES:${PN} = "onevpl"
33RCONFLICTS:${PN} = "onevpl"
34
35FILES:${PN}-examples = "${datadir}/vpl \
36 "
37
38FILES_SOLIBSDEV = ""
39FILES:${PN}-dev += "${libdir}/libvpl.so"
40
41FILES:${PN} += " ${datadir}/VPL/samples \
42 ${libdir}/vpl/libvpl_wayland.so \
43 "