summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/onevpl/onevpl_2023.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/onevpl/onevpl_2023.4.0.bb')
-rw-r--r--recipes-multimedia/onevpl/onevpl_2023.4.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-multimedia/onevpl/onevpl_2023.4.0.bb b/recipes-multimedia/onevpl/onevpl_2023.4.0.bb
new file mode 100644
index 00000000..513c7f2c
--- /dev/null
+++ b/recipes-multimedia/onevpl/onevpl_2023.4.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "oneAPI Video Processing Library"
2DESCRIPTION = "The oneAPI Video Processing Library (oneVPL) provides \
3a single video processing API for encode, decode, and video processing \
4that works across a wide range of accelerators."
5
6HOMEPAGE = "https://github.com/oneapi-src/oneVPL"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c18ea6bb4786a26bf4eee88a7424a408 \
9 file://third-party-programs.txt;md5=0e35a23482445dd089b4eabe19103a06"
10
11SRC_URI = "git://github.com/oneapi-src/oneVPL.git;protocol=https;branch=master \
12 file://0001-vpl.pc.in-dont-pass-pcfiledir-to-cflags.patch \
13 "
14SRCREV = "2274efcd3672b43297ef774f332e1fed6781381c"
15S = "${WORKDIR}/git"
16
17inherit cmake
18DEPENDS += "libva pkgconfig-native"
19
20PACKAGECONFIG ??= "tools"
21PACKAGECONFIG[tools] = "-DBUILD_TOOLS=ON, -DBUILD_TOOLS=OFF, wayland wayland-native wayland-protocols"
22
23do_install:append() {
24 mkdir -p ${D}${datadir}/oneVPL/samples
25 mv ${D}${bindir}/sample_* ${D}${datadir}/oneVPL/samples
26}
27
28COMPATIBLE_HOST = '(x86_64).*-linux'
29
30PACKAGES =+ "${PN}-examples"
31
32FILES:${PN}-examples = "${datadir}/vpl \
33 "
34
35FILES_SOLIBSDEV = ""
36FILES:${PN}-dev += "${libdir}/libvpl.so"
37
38FILES:${PN} += " ${datadir}/oneVPL/samples \
39 ${libdir}/vpl/libvpl_wayland.so \
40 "