summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/onevpl/onevpl_2023.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/onevpl/onevpl_2023.1.3.bb')
-rw-r--r--recipes-multimedia/onevpl/onevpl_2023.1.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-multimedia/onevpl/onevpl_2023.1.3.bb b/recipes-multimedia/onevpl/onevpl_2023.1.3.bb
new file mode 100644
index 00000000..c106efb6
--- /dev/null
+++ b/recipes-multimedia/onevpl/onevpl_2023.1.3.bb
@@ -0,0 +1,39 @@
1SUMMARY = "oneAPI Video Processing Library"
2DESCRIPTION = "The oneAPI Video Processing Library (oneVPL) provides \
3a single video processing API for encode, decode, and video processing \
4that works across a wide range of accelerators."
5
6HOMEPAGE = "https://github.com/oneapi-src/oneVPL"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c18ea6bb4786a26bf4eee88a7424a408 \
9 file://third-party-programs.txt;md5=f43d223f2b736e89abed9660483d0386"
10
11SRC_URI = "git://github.com/oneapi-src/oneVPL.git;protocol=https;branch=master \
12 "
13SRCREV = "4cdf44ccaa605460499c52f39eff5517da2fc3c8"
14S = "${WORKDIR}/git"
15
16inherit cmake
17DEPENDS += "libva pkgconfig-native"
18
19PACKAGECONFIG ??= "tools"
20PACKAGECONFIG[tools] = "-DBUILD_TOOLS=ON, -DBUILD_TOOLS=OFF, wayland wayland-native wayland-protocols"
21
22do_install:append() {
23 mkdir -p ${D}${datadir}/oneVPL/samples
24 mv ${D}${bindir}/sample_* ${D}${datadir}/oneVPL/samples
25}
26
27COMPATIBLE_HOST = '(x86_64).*-linux'
28
29PACKAGES =+ "${PN}-examples"
30
31FILES:${PN}-examples = "${datadir}/vpl \
32 "
33
34FILES_SOLIBSDEV = ""
35FILES:${PN}-dev += "${libdir}/libvpl.so"
36
37FILES:${PN} += " ${datadir}/oneVPL/samples \
38 ${libdir}/vpl/libvpl_wayland.so \
39 "