summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/onevpl/onevpl/0001-samples-use-find_program-to-detect-wayland-scanner-i.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/onevpl/onevpl/0001-samples-use-find_program-to-detect-wayland-scanner-i.patch')
-rw-r--r--recipes-multimedia/onevpl/onevpl/0001-samples-use-find_program-to-detect-wayland-scanner-i.patch108
1 files changed, 0 insertions, 108 deletions
diff --git a/recipes-multimedia/onevpl/onevpl/0001-samples-use-find_program-to-detect-wayland-scanner-i.patch b/recipes-multimedia/onevpl/onevpl/0001-samples-use-find_program-to-detect-wayland-scanner-i.patch
deleted file mode 100644
index 6f1ad93e..00000000
--- a/recipes-multimedia/onevpl/onevpl/0001-samples-use-find_program-to-detect-wayland-scanner-i.patch
+++ /dev/null
@@ -1,108 +0,0 @@
1From c69500c88058358bdc6c0a036d90b000d63f2a41 Mon Sep 17 00:00:00 2001
2From: "Ung, Teng En" <teng.en.ung@intel.com>
3Date: Wed, 3 Nov 2021 14:23:15 +0000
4Subject: [PATCH 4/4] samples: use find_program to detect wayland-scanner in
5 cmake
6
7Upstream-Status: Submitted
8innersource PR #269
9
10---
11 tools/legacy/sample_common/CMakeLists.txt | 4 +-
12 tools/legacy/sample_misc/wayland/CMakeLists.txt | 59 +++++++++++--------------
13 2 files changed, 28 insertions(+), 35 deletions(-)
14
15diff --git a/tools/legacy/sample_common/CMakeLists.txt b/tools/legacy/sample_common/CMakeLists.txt
16index 0ed8b39..658d44d 100644
17--- a/tools/legacy/sample_common/CMakeLists.txt
18+++ b/tools/legacy/sample_common/CMakeLists.txt
19@@ -93,10 +93,10 @@ if(UNIX)
20 ${TARGET}
21 PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../sample_misc/wayland/include)
22
23- pkg_check_modules(PKG_WAYLAND_SCANNER "wayland-scanner>=1.15")
24+ find_program(WAYLAND_SCANNER_BIN "wayland-scanner")
25 pkg_check_modules(PKG_WAYLAND_PROTCOLS "wayland-protocols>=1.15")
26
27- if(PKG_WAYLAND_SCANNER_FOUND AND PKG_WAYLAND_PROTCOLS_FOUND)
28+ if(WAYLAND_SCANNER_BIN AND PKG_WAYLAND_PROTCOLS_FOUND)
29 pkg_get_variable(WAYLAND_PROTOCOLS_PATH wayland-protocols pkgdatadir)
30 if(WAYLAND_PROTOCOLS_PATH)
31 find_file(
32diff --git a/tools/legacy/sample_misc/wayland/CMakeLists.txt b/tools/legacy/sample_misc/wayland/CMakeLists.txt
33index 01e6029..7625bc5 100644
34--- a/tools/legacy/sample_misc/wayland/CMakeLists.txt
35+++ b/tools/legacy/sample_misc/wayland/CMakeLists.txt
36@@ -29,43 +29,36 @@ target_sources(
37 ${CMAKE_CURRENT_SOURCE_DIR}/src/listener_wayland.cpp
38 ${CMAKE_CURRENT_SOURCE_DIR}/src/wayland-drm-protocol.c)
39
40-if(PKG_WAYLAND_SCANNER_FOUND AND PKG_WAYLAND_PROTCOLS_FOUND AND WAYLAND_LINUX_DMABUF_XML_PATH)
41- pkg_get_variable(WAYLAND_SCANNER_BIN_PATH wayland-scanner bindir)
42- pkg_get_variable(WAYLAND_SCANNER_BIN wayland-scanner wayland_scanner)
43+ if(WAYLAND_SCANNER_BIN AND PKG_WAYLAND_PROTCOLS_FOUND AND WAYLAND_LINUX_DMABUF_XML_PATH)
44
45- if(WAYLAND_SCANNER_BIN_PATH AND WAYLAND_SCANNER_BIN)
46- execute_process(
47- COMMAND "${WAYLAND_SCANNER_BIN_PATH}\/${WAYLAND_SCANNER_BIN}"
48- "client-header" "${WAYLAND_LINUX_DMABUF_XML_PATH}"
49- "tools/legacy/sample_misc/wayland/linux-dmabuf-unstable-v1.h"
50- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}"
51- RESULT_VARIABLE WAYLAND_SCANNER_RESULT)
52- if (WAYLAND_SCANNER_RESULT)
53- message(ERROR "Failed to generate linux-dmabuf-unstable-v1.h")
54- return()
55- endif()
56-
57- execute_process(
58- COMMAND "${WAYLAND_SCANNER_BIN_PATH}\/${WAYLAND_SCANNER_BIN}"
59- "private-code" "${WAYLAND_LINUX_DMABUF_XML_PATH}"
60- "tools/legacy/sample_misc/wayland/linux-dmabuf-unstable-v1.c"
61- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}"
62- RESULT_VARIABLE WAYLAND_SCANNER_RESULT)
63- if (WAYLAND_SCANNER_RESULT)
64- message(ERROR "Failed to generate linux-dmabuf-unstable-v1.c")
65- return()
66- endif()
67+ execute_process(
68+ COMMAND "${WAYLAND_SCANNER_BIN}"
69+ "client-header" "${WAYLAND_LINUX_DMABUF_XML_PATH}"
70+ "tools/legacy/sample_misc/wayland/linux-dmabuf-unstable-v1.h"
71+ WORKING_DIRECTORY "${CMAKE_BINARY_DIR}"
72+ RESULT_VARIABLE WAYLAND_SCANNER_RESULT)
73+ if (WAYLAND_SCANNER_RESULT)
74+ message(ERROR "Failed to generate linux-dmabuf-unstable-v1.h")
75+ return()
76+ endif()
77
78- include_directories(
79- ${CMAKE_BINARY_DIR}/tools/legacy/sample_misc/wayland)
80- add_definitions(-DWAYLAND_LINUX_DMABUF_SUPPORT)
81- target_sources(
82- ${TARGET}
83- PRIVATE ${CMAKE_BINARY_DIR}/tools/legacy/sample_misc/wayland/linux-dmabuf-unstable-v1.c)
84- else()
85- message(ERROR "Don't know how to execute wayland-scanner.")
86+ execute_process(
87+ COMMAND "${WAYLAND_SCANNER_BIN}"
88+ "private-code" "${WAYLAND_LINUX_DMABUF_XML_PATH}"
89+ "tools/legacy/sample_misc/wayland/linux-dmabuf-unstable-v1.c"
90+ WORKING_DIRECTORY "${CMAKE_BINARY_DIR}"
91+ RESULT_VARIABLE WAYLAND_SCANNER_RESULT)
92+ if (WAYLAND_SCANNER_RESULT)
93+ message(ERROR "Failed to generate linux-dmabuf-unstable-v1.c")
94 return()
95 endif()
96+
97+ include_directories(
98+ ${CMAKE_BINARY_DIR}/tools/legacy/sample_misc/wayland)
99+ add_definitions(-DWAYLAND_LINUX_DMABUF_SUPPORT)
100+ target_sources(
101+ ${TARGET}
102+ PRIVATE ${CMAKE_BINARY_DIR}/tools/legacy/sample_misc/wayland/linux-dmabuf-unstable-v1.c)
103 endif()
104
105 target_link_libraries(${TARGET} sample_common wayland-client va drm drm_intel)
106--
1072.7.4
108