summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb')
-rw-r--r--recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb b/recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb
new file mode 100644
index 00000000..2a2233e1
--- /dev/null
+++ b/recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Intel(R) oneVPL runtime for Intel GPU accelerated media processing"
2DESCRIPTION = "Intel(R) oneVPL runtime provides an runtime to access hardware-accelerated \
3video decode, encode and filtering on IntelĀ® graphics."
4
5HOMEPAGE = "https://github.com/oneapi-src/oneVPL-intel-gpu"
6BUGTRACKER = "https://github.com/oneapi-src/oneVPL-intel-gpu/issues"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=eb8cb45b9b57dbaa9fcc9adc4230202b"
10
11PE = "1"
12
13# Only for 64 bit
14COMPATIBLE_HOST = '(x86_64).*-linux'
15COMPATIBLE_HOST:x86-x32 = "null"
16
17DEPENDS += "libdrm libva intel-media-driver onevpl pkgconfig-native"
18RDEPENDS:${PN} += "intel-media-driver"
19
20SRC_URI = "git://github.com/oneapi-src/oneVPL-intel-gpu.git;protocol=https;nobranch=1;lfs=0 \
21 "
22
23SRCREV = "b2af8d128452c4b4c94399f051c3214f11c1dfa9"
24S = "${WORKDIR}/git"
25
26FILES:${PN} += " \
27 ${libdir}/libmfx-gen/enctools.so \
28 "
29
30inherit cmake