summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto_4.4.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-yocto_4.4.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto_4.4.bbappend33
1 files changed, 0 insertions, 33 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend
deleted file mode 100644
index 94450ce7..00000000
--- a/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.4.113"
4SRCREV_META_INTEL_COMMON = "b149d14ccae8349ab33e101f6af233a12f4b17ba"
5SRCREV_MACHINE_INTEL_COMMON = "ad0fe444fa68ae2cce203abceb71f6fb87bc6c7f"
6
7KBRANCH_INTEL_COMMON = "standard/intel/base"
8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
13KMACHINE_core2-32-intel-common = "intel-core2-32"
14KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
15SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
16SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
17KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18
19LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
20COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
21KMACHINE_corei7-64-intel-common = "intel-corei7-64"
22SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
23SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'a249f6388ace2a4035220c2333649b42c300faa9', '${SRCREV_MACHINE_INTEL_COMMON}', d)}"
24KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}"
25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
26
27# For Crystalforest and Romley
28KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
29KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
30
31# For FRI2, NUC
32KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
33KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"