summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_6.6.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_6.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_6.6.bb b/recipes-kernel/linux/linux-intel-rt_6.6.bb
new file mode 100644
index 00000000..342679eb
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_6.6.bb
@@ -0,0 +1,33 @@
1require linux-intel.inc
2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 "
5
6# Skip processing of this recipe if it is not explicitly specified as the
7# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
8# to build multiple virtual/kernel providers, e.g. as dependency of
9# core-image-rt-sdk, core-image-rt.
10python () {
11 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
12 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
13}
14
15KBRANCH = "6.6/preempt-rt"
16KMETA_BRANCH = "yocto-6.6"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
19
20DEPENDS += "elfutils-native openssl-native util-linux-native"
21
22LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
23
24LINUX_VERSION ?= "6.6.25"
25SRCREV_machine ?= "f8939454cf9bb7277239bb44e90c99474c599f37"
26SRCREV_meta ?= "c3d1322fb6ff68cdcf4d7a3c1140d81bfdc1320a"
27
28LINUX_KERNEL_TYPE = "preempt-rt"
29
30# Functionality flags
31KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
32
33UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v6.6.(\d+)-rt(\d)-preempt-rt-(\d+)T(\d+)Z)$"