summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_5.4.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
deleted file mode 100644
index 6b61e168..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14"
15
16KBRANCH = "5.4/preempt-rt"
17KMETA_BRANCH = "yocto-5.4"
18
19DEPENDS += "elfutils-native openssl-native util-linux-native"
20
21LINUX_VERSION ?= "5.4.102"
22SRCREV_machine ?= "7bbaa89ee7f0cb8e912e52b17247d0c0a7b2db15"
23SRCREV_meta ?= "19738ca97b999a3b150e2d34232bb44b6537348f"
24
25LINUX_KERNEL_TYPE = "preempt-rt"
26
27# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
28# linux-intel 5.4 specifically. This cause annoying warning during kernel config audit. So suppress the
29# harmless warning for now.
30KCONF_BSP_AUDIT_LEVEL = "0"