summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_5.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_5.10.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
deleted file mode 100644
index bba48759..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14 "
15
16KBRANCH = "5.10/preempt-rt"
17KMETA_BRANCH = "yocto-5.10"
18
19DEPENDS += "elfutils-native openssl-native util-linux-native"
20
21LINUX_VERSION ?= "5.10.59"
22SRCREV_machine ?= "3ab3139402e6adc34f10481f1c1c60459bcd0a7e"
23SRCREV_meta ?= "f8afd84b117f336477846b9e22178ebefb26c08d"
24
25LINUX_KERNEL_TYPE = "preempt-rt"
26
27# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
28# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
29# In which 'CONFIG_DRM_GMA3600' config option is dropped.
30# This causes warning during config audit. So suppress the harmless warning for now.
31KCONF_BSP_AUDIT_LEVEL = "0"
32
33# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
34# causes config warning too.
35KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"