summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb20
1 files changed, 0 insertions, 20 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
deleted file mode 100644
index 0b81987a..00000000
--- a/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1
2require linux-intel.inc
3
4# Skip processing of this recipe if it is not explicitly specified as the
5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
6# to build multiple virtual/kernel providers, e.g. as dependency of
7# core-image-rt-sdk, core-image-rt.
8python () {
9 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
11}
12
13KBRANCH = "4.9/yocto/base-rt"
14KMETA_BRANCH = "yocto-4.9"
15
16LINUX_VERSION ?= "4.9.84"
17SRCREV_machine ?= "33b17c3a62dc470c849f85ce2a90cfa90e96bcf5"
18SRCREV_meta ?= "bae5cc4e973f60baa35ed227ba0c3bdda4d16e87"
19
20LINUX_KERNEL_TYPE = "preempt-rt"