summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbevf_4.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbevf_4.3.5.bb')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf_4.3.5.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf_4.3.5.bb b/recipes-kernel/intel-ethernet/ixgbevf_4.3.5.bb
new file mode 100644
index 00000000..6f1ca081
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf_4.3.5.bb
@@ -0,0 +1,41 @@
1SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="This virtual function driver supports kernel versions 2.6.x and newer \
3This driver supports 82599, X540, X550, and X552-based virtual function devices \
4that can only be activated on kernels that support SR-IOV. \
5SR-IOV requires the correct platform and OS support. \
6The guest OS loading this driver must support MSI-X interrupts."
7
8HOMEPAGE = "https://sourceforge.net/projects/e1000/"
9SECTION = "kernel/network"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/${BP}.tar.gz \
14 file://0001-ixgbevf-skip-host-depmod.patch \
15 file://0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch \
16 "
17
18SRC_URI[md5sum] = "cdd9c52f034223c114d4b10345d11fe9"
19SRC_URI[sha256sum] = "f2ae017462bd1ea8082710580ec3dadfc322a0b2ecd4a576a16f0a4b622e5968"
20
21S = "${WORKDIR}/${BP}/src"
22MODULES_INSTALL_TARGET = "install"
23
24EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
25
26KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf"
27KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf"
28
29inherit module
30
31do_install_append () {
32 # Install scripts/set_irq_affinity
33 install -d ${D}${sysconfdir}/network
34 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network
35
36 rm -rf ${D}${prefix}/man
37}
38
39PACKAGES += "${PN}-script"
40
41FILES_${PN}-script += "${sysconfdir}/network/set_irq_affinity"