summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch38
-rw-r--r--recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch42
-rw-r--r--recipes-graphics/gmmlib/gmmlib_22.3.15.bb (renamed from recipes-graphics/gmmlib/gmmlib_21.1.1.bb)10
-rw-r--r--recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch2
-rw-r--r--recipes-graphics/hdcp/hdcp_21.2.0.bb (renamed from recipes-graphics/hdcp/hdcp_21.1.0.bb)6
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.20.1.bb (renamed from recipes-graphics/libva/libva-intel-utils_2.11.1.bb)6
-rw-r--r--recipes-graphics/libva/libva-intel_2.20.0.bb (renamed from recipes-graphics/libva/libva-intel_2.11.0.bb)23
-rw-r--r--recipes-graphics/metrics-discovery/metrics-discovery/0001-md_internal.h-Replace-string.h-with-string-C-header-.patch34
-rw-r--r--recipes-graphics/metrics-discovery/metrics-discovery_1.12.170.bb (renamed from recipes-graphics/metrics-discovery/metrics-discovery_1.5.108.bb)5
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-ast_1.1.6.bb (renamed from recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb)4
10 files changed, 109 insertions, 61 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
new file mode 100644
index 00000000..21cffe24
--- /dev/null
+++ b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
@@ -0,0 +1,38 @@
1From 8729d66800995a9b7e693bd78249932bd12383e1 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Mon, 25 Mar 2024 11:13:27 +0530
4Subject: [PATCH] Add new DG2 device IDs (#194)
5
6Upstream-status: Backport
7https://github.com/intel/gmmlib/commit/dcc4b85ea3728c848b62fbb164c00f43b519b6fb
8
9Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com>
10---
11 Source/inc/common/igfxfmid.h | 4 ++++
12 1 file changed, 4 insertions(+)
13
14diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
15index 7969779..8e2c955 100644
16--- a/Source/inc/common/igfxfmid.h
17+++ b/Source/inc/common/igfxfmid.h
18@@ -1932,6 +1932,8 @@ typedef enum __NATIVEGTTYPE
19 #define DEV_ID_56BB 0x56BB
20 #define DEV_ID_56BC 0x56BC
21 #define DEV_ID_56BD 0x56BD
22+#define DEV_ID_56BE 0x56BE
23+#define DEV_ID_56BF 0x56BF
24 #define DEV_ID_56C0 0x56C0
25 #define DEV_ID_56C1 0x56C1
26
27@@ -1992,6 +1994,8 @@ typedef enum __NATIVEGTTYPE
28 ( d == DEV_ID_5690 ) || \
29 ( d == DEV_ID_5691 ) || \
30 ( d == DEV_ID_5692 ) || \
31+ ( d == DEV_ID_56BE ) || \
32+ ( d == DEV_ID_56BF ) || \
33 ( d == DEV_ID_56C0 ) || \
34 ( d == DEV_ID_4F80 ) || \
35 ( d == DEV_ID_4F81 ) || \
36--
372.34.1
38
diff --git a/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch b/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch
new file mode 100644
index 00000000..ab4cb178
--- /dev/null
+++ b/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch
@@ -0,0 +1,42 @@
1From 2b267b72d6aaa922861b120da9c1543161797046 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Fri, 9 Feb 2024 13:10:18 +0530
4Subject: [PATCH] Introduce ARL-H support (#172)
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/544a8be6f66631e085c86c453aafd78b0e7f5179]
7Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
8---
9 Source/inc/common/igfxfmid.h | 10 ++++++++++
10 1 file changed, 10 insertions(+)
11
12diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
13index 99fc624..19aa505 100644
14--- a/Source/inc/common/igfxfmid.h
15+++ b/Source/inc/common/igfxfmid.h
16@@ -1966,6 +1966,11 @@ typedef enum __NATIVEGTTYPE
17 // ARL-S
18 #define DEV_ID_7D67 0x7D67
19
20+// ARL-H
21+#define DEV_ID_7D41 0x7D41
22+#define DEV_ID_7D51 0x7D51
23+#define DEV_ID_7DD1 0x7DD1
24+
25 #define MGM_HAS 0
26
27 //#define SDG_HAS 1 //Reserve place for Springdale-G HAS
28@@ -2012,6 +2017,11 @@ typedef enum __NATIVEGTTYPE
29 // Macro to identify ARL-S Device ID
30 #define GFX_IS_ARL_S(d) ( ( d == DEV_ID_7D67 ) )
31
32+// Macro to identify ARL-H Device ID
33+#define GFX_IS_ARL_H(d) ( ( d == DEV_ID_7D41 ) || \
34+ ( d == DEV_ID_7D51 ) || \
35+ ( d == DEV_ID_7DD1 ))
36+
37 //we define the highest cap and lower cap of stepping IDs
38 #define SI_REV_ID(lo,hi) (lo | hi<<16)
39
40--
412.40.1
42
diff --git a/recipes-graphics/gmmlib/gmmlib_21.1.1.bb b/recipes-graphics/gmmlib/gmmlib_22.3.15.bb
index f5de0ef5..875fbaf5 100644
--- a/recipes-graphics/gmmlib/gmmlib_21.1.1.bb
+++ b/recipes-graphics/gmmlib/gmmlib_22.3.15.bb
@@ -4,17 +4,19 @@ device specific and buffer management for the Intel(R) Graphics \
4Compute Runtime for OpenCL(TM) and the Intel(R) Media Driver for VAAPI." 4Compute Runtime for OpenCL(TM) and the Intel(R) Media Driver for VAAPI."
5 5
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=d9a6e772cd4c362ee4c8ef87c5aad843" 7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://github.com/intel/gmmlib.git;protocol=https \ 10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \
11 file://0001-Introduce-ARL-H-support-172.patch \
12 file://0001-Add-new-DG2-device-IDs-194.patch \
11 " 13 "
12 14
13SRCREV = "60a77187c43ff23a0888b2f297ae5c93cc50a666" 15SRCREV = "5fb4180e22695ad4e3c155cf680119913c9f44bc"
14 16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18
17COMPATIBLE_HOST_x86-x32 = "null" 19COMPATIBLE_HOST:x86-x32 = "null"
18 20
19UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$" 21UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$"
20 22
diff --git a/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch b/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch
index f07d466f..6d32da43 100644
--- a/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch
+++ b/recipes-graphics/hdcp/hdcp/0001-main-fix-hdcpd-service-failure.patch
@@ -9,7 +9,7 @@ exits, which causing hdcpd service failure.
9Added wait function to block parent process 9Added wait function to block parent process
10until child process exits. 10until child process exits.
11 11
12Upstream-Status: Submitted[https://github.com/intel/hdcp/pull/17] 12Upstream-Status: Submitted [https://github.com/intel/hdcp/pull/17]
13 13
14Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> 14Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
15--- 15---
diff --git a/recipes-graphics/hdcp/hdcp_21.1.0.bb b/recipes-graphics/hdcp/hdcp_21.2.0.bb
index 016e8e0a..8529b5ab 100644
--- a/recipes-graphics/hdcp/hdcp_21.1.0.bb
+++ b/recipes-graphics/hdcp/hdcp_21.2.0.bb
@@ -9,7 +9,7 @@ SECTION = "lib"
9 9
10inherit pkgconfig cmake useradd systemd features_check 10inherit pkgconfig cmake useradd systemd features_check
11 11
12SRC_URI = "git://github.com/intel/hdcp.git \ 12SRC_URI = "git://github.com/intel/hdcp.git;branch=master;protocol=https \
13 file://0001-main-fix-hdcpd-service-failure.patch \ 13 file://0001-main-fix-hdcpd-service-failure.patch \
14" 14"
15SRCREV = "cacc352159c5bdaf1c21846cecdd1eb7b031e1d3" 15SRCREV = "cacc352159c5bdaf1c21846cecdd1eb7b031e1d3"
@@ -20,7 +20,7 @@ REQUIRED_DISTRO_FEATURES = "systemd"
20DEPENDS = "libdrm virtual/mesa systemd" 20DEPENDS = "libdrm virtual/mesa systemd"
21 21
22USERADD_PACKAGES = "${PN}" 22USERADD_PACKAGES = "${PN}"
23USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false --gid nogroup media" 23USERADD_PARAM:${PN} = "--system --no-create-home --shell /bin/false --gid nogroup media"
24 24
25SYSTEMD_SERVICE_${PN} = "hdcpd.service" 25SYSTEMD_SERVICE:${PN} = "hdcpd.service"
26SYSTEMD_AUTO_ENABLE = "disable" 26SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/recipes-graphics/libva/libva-intel-utils_2.11.1.bb b/recipes-graphics/libva/libva-intel-utils_2.20.1.bb
index f9bea364..9c26f009 100644
--- a/recipes-graphics/libva/libva-intel-utils_2.11.1.bb
+++ b/recipes-graphics/libva/libva-intel-utils_2.20.1.bb
@@ -14,8 +14,8 @@ SECTION = "x11"
14LICENSE = "MIT" 14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e" 15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16 16
17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.11-branch" 17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.20-branch;protocol=https"
18SRCREV = "959b2f20cf99d4611eab66164af3d7e4a84f674b" 18SRCREV = "2ad888bb463dc9bfb3deb512ec9faf78f1d3bfa8"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" 21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
@@ -32,4 +32,4 @@ PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland" 32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland"
33 33
34PROVIDES = "libva-utils" 34PROVIDES = "libva-utils"
35RPROVIDES_${PN} += "libva-utils" 35RPROVIDES:${PN} += "libva-utils"
diff --git a/recipes-graphics/libva/libva-intel_2.11.0.bb b/recipes-graphics/libva/libva-intel_2.20.0.bb
index 406f6f68..c81ed65c 100644
--- a/recipes-graphics/libva/libva-intel_2.11.0.bb
+++ b/recipes-graphics/libva/libva-intel_2.20.0.bb
@@ -17,8 +17,9 @@ SECTION = "x11"
17LICENSE = "MIT" 17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" 18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19 19
20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2" 20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2 \
21SRC_URI[sha256sum] = "6e361117038b571ad4741d38c9280db8c140b17e76e8c01fc7a4d608d3ed7d5d" 21 "
22SRC_URI[sha256sum] = "f72bdb4f48dfe71ad01f1cbefe069672a2c949a6abd51cf3c4d4784210badc49"
22 23
23S = "${WORKDIR}/libva-${PV}" 24S = "${WORKDIR}/libva-${PV}"
24 25
@@ -40,15 +41,15 @@ PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wa
40 41
41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" 42PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
42 43
43RDEPENDS_${PN}-x11 =+ "${PN}" 44RDEPENDS:${PN}-x11 =+ "${PN}"
44RDEPENDS_${PN}-glx =+ "${PN}-x11" 45RDEPENDS:${PN}-glx =+ "${PN}-x11"
45 46
46FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" 47FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" 48FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" 49FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
49 50
50PROVIDES += "libva" 51PROVIDES += "libva"
51RPROVIDES_${PN} += "libva" 52RPROVIDES:${PN} += "libva"
52RPROVIDES_${PN}-x11 += "libva-x11" 53RPROVIDES:${PN}-x11 += "libva-x11"
53RPROVIDES_${PN}-glx += "libva-glx" 54RPROVIDES:${PN}-glx += "libva-glx"
54RPROVIDES_${PN}-wayland += "libva-wayland" 55RPROVIDES:${PN}-wayland += "libva-wayland"
diff --git a/recipes-graphics/metrics-discovery/metrics-discovery/0001-md_internal.h-Replace-string.h-with-string-C-header-.patch b/recipes-graphics/metrics-discovery/metrics-discovery/0001-md_internal.h-Replace-string.h-with-string-C-header-.patch
deleted file mode 100644
index d97c6543..00000000
--- a/recipes-graphics/metrics-discovery/metrics-discovery/0001-md_internal.h-Replace-string.h-with-string-C-header-.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 8c11096a0e5cf980309692ae3e272108da5f2b4e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 9 Oct 2019 11:36:56 -0700
4Subject: [PATCH] md_internal.h: Replace string.h with <string> C++ header API
5
6This helps in compiling with libc++/Clang
7Fixes
8usr/include/c++/v1/type_traits:1561:38: error: implicit instantiation of undefined template 'std::__1::hash<std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > >'
9: public integral_constant<bool, __is_empty(_Tp)> {};
10^
11
12Upstream-Status: Submitted [https://github.com/intel/metrics-discovery/pull/14]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 instrumentation/metrics_discovery/common/md_internal.cpp | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/instrumentation/metrics_discovery/common/md_internal.cpp b/instrumentation/metrics_discovery/common/md_internal.cpp
19index f9571ac..0767e81 100644
20--- a/instrumentation/metrics_discovery/common/md_internal.cpp
21+++ b/instrumentation/metrics_discovery/common/md_internal.cpp
22@@ -27,8 +27,8 @@
23 \*****************************************************************************/
24 #include "md_internal.h"
25
26-#include <string.h>
27 #include <stdlib.h>
28+#include <string>
29 #include <new>
30 #include <unordered_map>
31
32--
332.23.0
34
diff --git a/recipes-graphics/metrics-discovery/metrics-discovery_1.5.108.bb b/recipes-graphics/metrics-discovery/metrics-discovery_1.12.170.bb
index da7cb652..3ed1c9bd 100644
--- a/recipes-graphics/metrics-discovery/metrics-discovery_1.5.108.bb
+++ b/recipes-graphics/metrics-discovery/metrics-discovery_1.12.170.bb
@@ -8,9 +8,8 @@ SECTION = "lib"
8inherit pkgconfig cmake 8inherit pkgconfig cmake
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11SRCREV = "a495db4682b7318bc82b1cccfb17fafdf2e3a2ff" 11SRCREV = "75b292eb1309e4ea10dce403065ee8ca5bf29ecc"
12SRC_URI = "git://github.com/intel/metrics-discovery.git \ 12SRC_URI = "git://github.com/intel/metrics-discovery.git;branch=master;protocol=https \
13 file://0001-md_internal.h-Replace-string.h-with-string-C-header-.patch \
14 " 13 "
15 14
16EXTRA_OECMAKE += "-DMD_PLATFORM=linux" 15EXTRA_OECMAKE += "-DMD_PLATFORM=linux"
diff --git a/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb b/recipes-graphics/xorg-driver/xf86-video-ast_1.1.6.bb
index 090efd62..d7e4eab4 100644
--- a/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-ast_1.1.6.bb
@@ -7,6 +7,6 @@ DESCRIPTION = "ast is an Xorg driver for ASpeed Technologies video cards"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0b8c242f0218eea5caa949b7910a774b" 7LIC_FILES_CHKSUM = "file://COPYING;md5=0b8c242f0218eea5caa949b7910a774b"
8 8
9DEPENDS += "libpciaccess" 9DEPENDS += "libpciaccess"
10XORG_DRIVER_COMPRESSOR = ".tar.gz"
10 11
11SRC_URI[md5sum] = "4f85febe48d51e53624550a96fc9e9ee" 12SRC_URI[sha256sum] = "eeff52178ce2916a0e07b531bb23c8b105826b6e6e6c5f7c90e33f757827a7c7"
12SRC_URI[sha256sum] = "1edbbc55d47d3fd71dec99b15c2483e22738c642623a0fb86ef4a81a9067a2de"