summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch34
-rw-r--r--recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch42
-rw-r--r--recipes-graphics/gmmlib/gmmlib_22.3.18.bb (renamed from recipes-graphics/gmmlib/gmmlib_22.3.15.bb)4
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.21.0.bb (renamed from recipes-graphics/libva/libva-intel-utils_2.20.1.bb)4
-rw-r--r--recipes-graphics/libva/libva-intel_2.21.0.bb (renamed from recipes-graphics/libva/libva-intel_2.20.0.bb)7
-rw-r--r--recipes-graphics/metrics-discovery/metrics-discovery_1.12.171.bb (renamed from recipes-graphics/metrics-discovery/metrics-discovery_1.12.170.bb)2
6 files changed, 43 insertions, 50 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
new file mode 100644
index 00000000..195b3c58
--- /dev/null
+++ b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch
@@ -0,0 +1,34 @@
1From 683f3552e7d5089601bb37952641b1c7691cf475 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Mon, 25 Mar 2024 11:13:27 +0530
4Subject: [PATCH] Add new DG2 device IDs (#194)
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/dcc4b85ea3728c848b62fbb164c00f43b519b6fb]
7
8Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com>
9---
10 Source/inc/common/igfxfmid.h | 4 ++++
11 1 file changed, 4 insertions(+)
12
13diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
14index 1264087..e944e1e 100644
15--- a/Source/inc/common/igfxfmid.h
16+++ b/Source/inc/common/igfxfmid.h
17@@ -1934,6 +1934,8 @@ typedef enum __NATIVEGTTYPE
18 #define DEV_ID_56BB 0x56BB
19 #define DEV_ID_56BC 0x56BC
20 #define DEV_ID_56BD 0x56BD
21+#define DEV_ID_56BE 0x56BE
22+#define DEV_ID_56BF 0x56BF
23 #define DEV_ID_56C0 0x56C0
24 #define DEV_ID_56C1 0x56C1
25 #define DEV_ID_56C2 0x56C2
26@@ -2001,6 +2003,8 @@ typedef enum __NATIVEGTTYPE
27 ( d == DEV_ID_5690 ) || \
28 ( d == DEV_ID_5691 ) || \
29 ( d == DEV_ID_5692 ) || \
30+ ( d == DEV_ID_56BE ) || \
31+ ( d == DEV_ID_56BF ) || \
32 ( d == DEV_ID_56C0 ) || \
33 ( d == DEV_ID_56C2 ) || \
34 ( d == DEV_ID_4F80 ) || \
diff --git a/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch b/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch
deleted file mode 100644
index ab4cb178..00000000
--- a/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 2b267b72d6aaa922861b120da9c1543161797046 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Fri, 9 Feb 2024 13:10:18 +0530
4Subject: [PATCH] Introduce ARL-H support (#172)
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/544a8be6f66631e085c86c453aafd78b0e7f5179]
7Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
8---
9 Source/inc/common/igfxfmid.h | 10 ++++++++++
10 1 file changed, 10 insertions(+)
11
12diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
13index 99fc624..19aa505 100644
14--- a/Source/inc/common/igfxfmid.h
15+++ b/Source/inc/common/igfxfmid.h
16@@ -1966,6 +1966,11 @@ typedef enum __NATIVEGTTYPE
17 // ARL-S
18 #define DEV_ID_7D67 0x7D67
19
20+// ARL-H
21+#define DEV_ID_7D41 0x7D41
22+#define DEV_ID_7D51 0x7D51
23+#define DEV_ID_7DD1 0x7DD1
24+
25 #define MGM_HAS 0
26
27 //#define SDG_HAS 1 //Reserve place for Springdale-G HAS
28@@ -2012,6 +2017,11 @@ typedef enum __NATIVEGTTYPE
29 // Macro to identify ARL-S Device ID
30 #define GFX_IS_ARL_S(d) ( ( d == DEV_ID_7D67 ) )
31
32+// Macro to identify ARL-H Device ID
33+#define GFX_IS_ARL_H(d) ( ( d == DEV_ID_7D41 ) || \
34+ ( d == DEV_ID_7D51 ) || \
35+ ( d == DEV_ID_7DD1 ))
36+
37 //we define the highest cap and lower cap of stepping IDs
38 #define SI_REV_ID(lo,hi) (lo | hi<<16)
39
40--
412.40.1
42
diff --git a/recipes-graphics/gmmlib/gmmlib_22.3.15.bb b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb
index 5928fb86..134a6461 100644
--- a/recipes-graphics/gmmlib/gmmlib_22.3.15.bb
+++ b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb
@@ -8,10 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \ 10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \
11 file://0001-Introduce-ARL-H-support-172.patch \ 11 file://0001-Add-new-DG2-device-IDs-194.patch \
12 " 12 "
13 13
14SRCREV = "5fb4180e22695ad4e3c155cf680119913c9f44bc" 14SRCREV = "ac964bdffdda7730e8234511f61016071e63783b"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
diff --git a/recipes-graphics/libva/libva-intel-utils_2.20.1.bb b/recipes-graphics/libva/libva-intel-utils_2.21.0.bb
index 9c26f009..0407aa18 100644
--- a/recipes-graphics/libva/libva-intel-utils_2.20.1.bb
+++ b/recipes-graphics/libva/libva-intel-utils_2.21.0.bb
@@ -14,8 +14,8 @@ SECTION = "x11"
14LICENSE = "MIT" 14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e" 15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16 16
17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.20-branch;protocol=https" 17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.21-branch;protocol=https"
18SRCREV = "2ad888bb463dc9bfb3deb512ec9faf78f1d3bfa8" 18SRCREV = "5a59217d5d288f7671ca18d3764139289d83a93e"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" 21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
diff --git a/recipes-graphics/libva/libva-intel_2.20.0.bb b/recipes-graphics/libva/libva-intel_2.21.0.bb
index c81ed65c..83fb3646 100644
--- a/recipes-graphics/libva/libva-intel_2.20.0.bb
+++ b/recipes-graphics/libva/libva-intel_2.21.0.bb
@@ -17,11 +17,12 @@ SECTION = "x11"
17LICENSE = "MIT" 17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" 18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19 19
20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2 \ 20SRC_URI = "git://github.com/intel/libva.git;protocol=https;branch=v2.21-branch \
21 " 21 "
22SRC_URI[sha256sum] = "f72bdb4f48dfe71ad01f1cbefe069672a2c949a6abd51cf3c4d4784210badc49"
23 22
24S = "${WORKDIR}/libva-${PV}" 23SRCREV = "0b01aed44ef1a6ad660261284ff266fa812829ef"
24
25S = "${WORKDIR}/git"
25 26
26UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases" 27UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
27 28
diff --git a/recipes-graphics/metrics-discovery/metrics-discovery_1.12.170.bb b/recipes-graphics/metrics-discovery/metrics-discovery_1.12.171.bb
index 3ed1c9bd..d3f32c25 100644
--- a/recipes-graphics/metrics-discovery/metrics-discovery_1.12.170.bb
+++ b/recipes-graphics/metrics-discovery/metrics-discovery_1.12.171.bb
@@ -8,7 +8,7 @@ SECTION = "lib"
8inherit pkgconfig cmake 8inherit pkgconfig cmake
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11SRCREV = "75b292eb1309e4ea10dce403065ee8ca5bf29ecc" 11SRCREV = "24c4dfd45df1600ca83dfb03217675edc4633ffd"
12SRC_URI = "git://github.com/intel/metrics-discovery.git;branch=master;protocol=https \ 12SRC_URI = "git://github.com/intel/metrics-discovery.git;branch=master;protocol=https \
13 " 13 "
14 14