summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch68
1 files changed, 0 insertions, 68 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch b/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch
deleted file mode 100644
index ceae6dfb..00000000
--- a/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch
+++ /dev/null
@@ -1,68 +0,0 @@
1Upstream-Status: Submitted [https://bugs.freedesktop.org/show_bug.cgi?id=57606]
2Signed-off-by: Ross Burton <ross.burton@intel.com>
3
4From c9014a8f3c9b691b5aa7b1f3ec66cf7c84b8211b Mon Sep 17 00:00:00 2001
5From: Ross Burton <ross.burton@intel.com>
6Date: Thu, 29 Nov 2012 11:00:43 +0000
7Subject: [PATCH] build: dont use AC_CHECK_FILE when enabling DRI
8
9Automatically enabling or disabling a feature based on installed files isn't
10deterministic, and AC_CHECK_FILE returns an error when cross-compiling.
11
12Fix this by enabling DRI by default, and removing the explicit file checks as
13pkg-config is good enough.
14
15(#57606)
16
17Signed-off-by: Ross Burton <ross.burton@intel.com>
18---
19 configure.ac | 25 ++-----------------------
20 1 file changed, 2 insertions(+), 23 deletions(-)
21
22diff --git a/configure.ac b/configure.ac
23index fca1a9c..d2aa2ed 100644
24--- a/configure.ac
25+++ b/configure.ac
26@@ -55,9 +55,9 @@ AC_ARG_WITH(xorg-module-dir,
27 [moduledir="$libdir/xorg/modules"])
28
29 AC_ARG_ENABLE(dri, AS_HELP_STRING([--disable-dri],
30- [Disable DRI support [[default=auto]]]),
31+ [Disable DRI support [[default=enabled]]]),
32 [DRI="$enableval"],
33- [DRI=auto])
34+ [DRI=yes])
35 AC_ARG_ENABLE(exa,
36 AS_HELP_STRING([--disable-exa],
37 [Disable EXA support [[default=enabled]]]),
38@@ -76,27 +76,6 @@ sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
39
40 # Checks for libraries.
41
42-if test "x$DRI" != xno; then
43- AC_CHECK_FILE([${sdkdir}/dri.h],
44- [have_dri_h="yes"], [have_dri_h="no"])
45- AC_CHECK_FILE([${sdkdir}/sarea.h],
46- [have_sarea_h="yes"], [have_sarea_h="no"])
47- AC_CHECK_FILE([${sdkdir}/dristruct.h],
48- [have_dristruct_h="yes"], [have_dristruct_h="no"])
49-fi
50-
51-AC_MSG_CHECKING([whether to include DRI support])
52-if test "x$DRI" = xauto; then
53- if test "x$have_dri_h" = xyes && \
54- test "x$have_sarea_h" = xyes && \
55- test "x$have_dristruct_h" = xyes; then
56- DRI="yes"
57- else
58- DRI="no"
59- fi
60-fi
61-AC_MSG_RESULT([$DRI])
62-
63 AM_CONDITIONAL(DRI, test "x$DRI" = xyes)
64 if test "x$DRI" = xyes; then
65 PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto])
66--
671.7.10.4
68