summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/opencl/opencl-clang-native_8.0.0.bb25
-rw-r--r--recipes-devtools/slimboot/slimboot-tools_git.bb22
2 files changed, 22 insertions, 25 deletions
diff --git a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
deleted file mode 100644
index cfba8d97..00000000
--- a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https"
9
10SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15"
11
12S = "${WORKDIR}/git"
13
14inherit native
15
16do_configure[noexec] = "1"
17
18do_compile() {
19 ${CC} linux_linker/linux_resource_linker.cpp -o linux_resource_linker
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 linux_resource_linker ${D}${bindir}/
25}
diff --git a/recipes-devtools/slimboot/slimboot-tools_git.bb b/recipes-devtools/slimboot/slimboot-tools_git.bb
new file mode 100644
index 00000000..b65b182d
--- /dev/null
+++ b/recipes-devtools/slimboot/slimboot-tools_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Slim Bootloader Host Tools"
2DESCRIPTION = "Native host tools to generate the container images in a \
3binary file format understood by Slim Bootloader to load and initialize\
4Operating Systems or Hypervisors."
5HOMEPAGE = "https://slimbootloader.github.io/tools/index.html"
6
7SRC_URI = "git://github.com/slimbootloader/slimbootloader;protocol=https;branch=master"
8SRCREV = "df5bd0bc2a522afcb8945a6797592b04838db753"
9PV = "0.0.0+git${SRCPV}"
10LICENSE = "BSD-2-Clause-Patent"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=ef7fba7be2819ac13aaf5d0f842ce5d9"
12S = "${WORKDIR}/git"
13
14inherit python3native
15BBCLASSEXTEND = "native"
16
17do_configure[noexec] = "1"
18do_compile[noexec] = "1"
19do_install() {
20 install -m 755 -d ${D}${libexecdir}/slimboot/Tools
21 install -m 755 ${S}/BootloaderCorePkg/Tools/*.py ${D}${libexecdir}/slimboot/Tools
22}