summaryrefslogtreecommitdiffstats
path: root/recipes-core/mkl-dnn/mkl-dnn_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/mkl-dnn/mkl-dnn_1.1.bb')
-rw-r--r--recipes-core/mkl-dnn/mkl-dnn_1.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-core/mkl-dnn/mkl-dnn_1.1.bb b/recipes-core/mkl-dnn/mkl-dnn_1.1.bb
new file mode 100644
index 00000000..799a58aa
--- /dev/null
+++ b/recipes-core/mkl-dnn/mkl-dnn_1.1.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Deep Neural Network Library"
2DESCRIPTION = "This software is a user mode library that accelerates\
3deep-learning applications and frameworks on Intel architecture."
4LICENSE = "Apache-2.0 & BSD-3-Clause & BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=477df9cc728dd9c63128c0f3525f4649 \
6 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
7 file://src/cpu/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
8 file://src/cpu/jit_utils/jitprofiling/LICENSE.BSD;md5=e671ff178b24a95a382ba670503c66fb \
9 file://cmake/Copyright.txt;md5=622747147b46f22e1953876a7cba3323 \
10 file://doc/assets/mathjax/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
11 file://src/common/LICENSE_1_0;md5=e4224ccaecb14d942c71d31bef20d78c \
12 "
13SECTION = "lib"
14
15inherit pkgconfig cmake ptest
16
17S = "${WORKDIR}/git"
18SRCREV = "dc6c0f3897c910a6ccba7f1db1f8d6f318c04f16"
19SRC_URI = "git://github.com/intel/mkl-dnn.git;branch=rls-v1.1 \
20 file://run-ptest \
21 "
22
23UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
24
25COMPATIBLE_HOST = '(x86_64).*-linux'
26COMPATIBLE_HOST_libc-musl = 'null'
27
28EXTRA_OECMAKE += "-DDNNL_LIBRARY_TYPE=SHARED"
29EXTRA_OECMAKE += "-DDNNL_THREADING=OMP"
30EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON"
31EXTRA_OECMAKE += "-DWITH_TEST=ON"
32EXTRA_OECMAKE += "-DARCH_OPT_FLAGS=''"
33EXTRA_OECMAKE += "-DCMAKE_SKIP_RPATH=ON"
34
35do_install_append () {
36 install -d ${D}${bindir}/mkl-dnn
37 install -d ${D}${bindir}/mkl-dnn/tests
38 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn
39 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
40 install -m 0755 ${B}/tests/benchdnn/benchdnn ${D}${bindir}/mkl-dnn/tests/benchdnn
41 cp -r ${B}/tests/benchdnn/inputs/* ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
42}
43
44
45do_install_ptest () {
46 install -d ${D}${PTEST_PATH}/tests
47 install -m 0755 ${B}/tests/api-c ${D}${PTEST_PATH}/tests
48 install -m 0755 ${B}/tests/test_c_symbols-c ${D}${PTEST_PATH}/tests
49}
50
51PACKAGES =+ "${PN}-test"
52
53FILES_${PN}-test = "${bindir}/mkl-dnn/*"