summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/formfactor/formfactor_0.0.bbappend2
-rw-r--r--recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb29
-rw-r--r--recipes-bsp/metee/metee_3.2.4.bb (renamed from recipes-bsp/metee/metee_2.2.2.bb)5
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot_%.bbappend9
-rw-r--r--recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch27
-rw-r--r--recipes-bsp/thermald/thermald_2.2.bb36
6 files changed, 33 insertions, 75 deletions
diff --git a/recipes-bsp/formfactor/formfactor_0.0.bbappend b/recipes-bsp/formfactor/formfactor_0.0.bbappend
index 6dd422ae..d21c3bee 100644
--- a/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -1 +1 @@
FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" FILESEXTRAPATHS:prepend:intel-x86-common := "${THISDIR}/${PN}:"
diff --git a/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb
new file mode 100644
index 00000000..60d0dfd2
--- /dev/null
+++ b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "intel-cmt-cat"
2DESCRIPTION = "Software package which provides basic support for Intel(R) \
3Resource Director Technology (Intel(R) RDT)"
4HOMEPAGE = "https://github.com/intel/intel-cmt-cat"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4b63c65942e1c16fd897f8cd20abebf8"
8
9SRC_URI = "git://github.com/intel/intel-cmt-cat;protocol=https;branch=master"
10SRCREV = "b26b31b0ae6980c5939a421cefe0316cae884626"
11
12S = "${WORKDIR}/git"
13
14COMPATIBLE_HOST = '(x86_64).*-linux'
15COMPATIBLE_HOST:libc-musl = "null"
16
17do_install() {
18 oe_runmake install PREFIX=${D}${prefix} NOLDCONFIG=y
19}
20
21FILES:${PN} += "${nonarch_libdir}/libpqos*"
22FILES:${PN}-doc = "/usr/man*"
23
24INSANE_SKIP:${PN} += "ldflags"
25INSANE_SKIP:${PN} += "dev-so"
26INSANE_SKIP:${PN} += "libdir"
27INSANE_SKIP:${PN} += "already-stripped"
28
29INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/recipes-bsp/metee/metee_2.2.2.bb b/recipes-bsp/metee/metee_3.2.4.bb
index 0bd10b02..da8220b9 100644
--- a/recipes-bsp/metee/metee_2.2.2.bb
+++ b/recipes-bsp/metee/metee_3.2.4.bb
@@ -10,8 +10,9 @@ COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10 10
11inherit cmake 11inherit cmake
12 12
13SRC_URI = "git://github.com/intel/metee.git" 13SRC_URI = "git://github.com/intel/metee.git;branch=master;protocol=https \
14SRCREV = "f4761a13bd7b3e5d1b7d9f56a1d64b3b0c13d6e6" 14"
15SRCREV = "db45e37e146fd9c06907a15ade55eba06ad1f951"
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
17 18
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
deleted file mode 100644
index d2e1c16b..00000000
--- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
1PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
2
3do_compile_append_intel-x86-common() {
4 ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
5}
6
7do_deploy_append_intel-x86-common() {
8 install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
9}
diff --git a/recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch b/recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch
deleted file mode 100644
index b8639e0e..00000000
--- a/recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From b20692607ec8b0895c5ac0c23b0393ad3048640d Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 22 Jun 2020 09:34:51 +0800
4Subject: [PATCH] configure.ac: disable werror
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 configure.ac | 1 -
11 1 file changed, 1 deletion(-)
12
13diff --git a/configure.ac b/configure.ac
14index 7d6c13c..3e1a8bf 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -84,7 +84,6 @@ for flag in \
18 -Wall \
19 -Wclobbered \
20 -Wempty-body \
21- -Werror \
22 -Wformat \
23 -Wignored-qualifiers \
24 -Wmissing-field-initializers \
25--
262.25.4
27
diff --git a/recipes-bsp/thermald/thermald_2.2.bb b/recipes-bsp/thermald/thermald_2.2.bb
deleted file mode 100644
index 6da1291d..00000000
--- a/recipes-bsp/thermald/thermald_2.2.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
12
13SRC_URI = "git://github.com/intel/thermal_daemon/ \
14 file://0001-configure.ac-disable-werror.patch \
15 "
16SRCREV = "4f0e68974c26749191ac945586b8cc97800d5d02"
17S = "${WORKDIR}/git"
18
19inherit pkgconfig autotools systemd
20
21EXTRA_OECONF = " \
22 --with-systemdsystemunitdir=${systemd_system_unitdir} \
23 "
24
25FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
26
27SYSTEMD_SERVICE_${PN} = "thermald.service"
28
29COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
30
31CONFFILES_${PN} = " \
32 ${sysconfdir}/thermald/thermal-conf.xml \
33 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
34 "
35
36UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"