summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ace/ace_6.5.3.bb40
-rw-r--r--recipes-bsp/ace/files/ace_config.patch12
-rw-r--r--recipes-bsp/ace/files/config_linux.patch30
-rw-r--r--recipes-bsp/formfactor/formfactor_0.0.bbappend2
-rw-r--r--recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf2
-rw-r--r--recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh15
-rw-r--r--recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb18
-rw-r--r--recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb29
-rw-r--r--recipes-bsp/metee/metee_3.2.4.bb (renamed from recipes-bsp/metee/metee_2.1.1.bb)5
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot_%.bbappend9
-rw-r--r--recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch45
-rw-r--r--recipes-bsp/thermald/thermald_1.9.bb35
12 files changed, 33 insertions, 209 deletions
diff --git a/recipes-bsp/ace/ace_6.5.3.bb b/recipes-bsp/ace/ace_6.5.3.bb
deleted file mode 100644
index f1a10eea..00000000
--- a/recipes-bsp/ace/ace_6.5.3.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "C++ framework for implementing distributed and networked applications"
2DESCRIPTION = "C++ network programming framework that implements many core \
3patterns for concurrent communication software"
4LICENSE = "ACE-TAO-CIAO"
5HOMEPAGE = "http://www.dre.vanderbilt.edu/~schmidt/ACE.html"
6LIC_FILES_CHKSUM = "file://COPYING;md5=407a202d1b887b998dc9480442840630"
7
8DEPENDS += "openssl gperf-native"
9
10SRC_URI = "ftp://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 \
11 file://ace_config.patch \
12 file://config_linux.patch \
13 "
14
15SRC_URI[md5sum] = "4cc5f109ebd17cd56f0539d1b47d16b3"
16SRC_URI[sha256sum] = "b1d6a716394bd15c21bb90037b8a12a4d8034cc9d8878b0ad39b3c467df19b1a"
17
18COMPATIBLE_HOST_libc-musl = "null"
19
20S = "${WORKDIR}/ACE_wrappers"
21B = "${WORKDIR}/ACE_wrappers/ace"
22export ACE_ROOT="${WORKDIR}/ACE_wrappers"
23
24inherit pkgconfig
25
26CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations"
27
28do_install() {
29 export D="${D}"
30 oe_runmake install
31
32 for i in $(find ${D} -name "*.pc") ; do
33 sed -i -e s:${D}::g \
34 -e s:/${TARGET_SYS}::g \
35 $i
36 done
37
38 rm -r ${D}/usr/share
39}
40
diff --git a/recipes-bsp/ace/files/ace_config.patch b/recipes-bsp/ace/files/ace_config.patch
deleted file mode 100644
index 207b85ab..00000000
--- a/recipes-bsp/ace/files/ace_config.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -ruN ACE_wrappers1/ace/config.h ACE_wrappers/ace/config.h
2--- ACE_wrappers1/ace/config.h 1970-01-01 02:00:00.000000000 +0200
3+++ ACE_wrappers/ace/config.h 2019-01-10 13:36:52.698012477 +0200
4@@ -0,0 +1,1 @@
5+#include "ace/config-linux.h"
6diff -ruN ACE_wrappers1/include/makeinclude/platform_macros.GNU ACE_wrappers/include/makeinclude/platform_macros.GNU
7--- ACE_wrappers1/include/makeinclude/platform_macros.GNU 1970-01-01 02:00:00.000000000 +0200
8+++ ACE_wrappers/include/makeinclude/platform_macros.GNU 2018-10-31 15:11:18.265392460 +0200
9@@ -0,0 +1,3 @@
10+INSTALL_PREFIX = $(D)$(exec_prefix)
11+INSTALL_LIB = $(base_libdir)
12+include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU
diff --git a/recipes-bsp/ace/files/config_linux.patch b/recipes-bsp/ace/files/config_linux.patch
deleted file mode 100644
index 323a63eb..00000000
--- a/recipes-bsp/ace/files/config_linux.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1config-linux.h: fix glibc build failure
2
3Recent glibc v2.30 dropped XSI STREAMS declarations,
4which causing below build failure.
5
6poky/build/tmp/work/corei7-64-poky-linux/ace/6.5.3-r0/ACE_wrappers/ace/os_include/os_stropts.h:56:17: fatal error: stropts.h: No such file or directory
7| 56 | # include /**/ <stropts.h>
8| | ^~~~~~~~~~~
9| compilation terminated.
10
11Added GLIBC checks for affected versions.
12
13For more information about glibc v2.30 change, please check:
14https://sourceware.org/git/?p=glibc.git;a=commit;h=a0a0dc83173ce11ff45105fd32e5d14356cdfb9c
15
16Upstream-Status: Submitted [https://github.com/DOCGroup/ACE_TAO/pull/939]
17
18Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
19
20--- ACE_wrappers_original/ace/config-linux.h 2018-11-19 17:45:53.163139000 +0800
21+++ ACE_wrappers/ace/config-linux.h 2019-08-13 17:04:17.620866464 +0800
22@@ -295,7 +295,7 @@
23
24 // Starting with FC9 rawhide this file is not available anymore but
25 // this define is set
26-#if defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1
27+#if (defined(__GLIBC__) && (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 30)) || (defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1)
28 # define ACE_LACKS_STROPTS_H
29 # define ACE_LACKS_STRRECVFD
30 #endif
diff --git a/recipes-bsp/formfactor/formfactor_0.0.bbappend b/recipes-bsp/formfactor/formfactor_0.0.bbappend
index 6dd422ae..d21c3bee 100644
--- a/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -1 +1 @@
FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" FILESEXTRAPATHS:prepend:intel-x86-common := "${THISDIR}/${PN}:"
diff --git a/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf b/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf
deleted file mode 100644
index 74d33c87..00000000
--- a/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf
+++ /dev/null
@@ -1,2 +0,0 @@
1# Mimic modprobe's install funcitonality with busybox's modprobe
2install gma500_gfx dmesg | grep gma500_gfx_checked || { /etc/modprobe.d/gma500-gfx-check.sh || modprobe gma500_gfx; }
diff --git a/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh b/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh
deleted file mode 100644
index 75cda99f..00000000
--- a/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh
+++ /dev/null
@@ -1,15 +0,0 @@
1#!/bin/sh
2
3# Check for devices we wish to avoid gma500_gfx for
4DEVICES="0x8119 0x4108"
5
6# Checked flag to avoid infinite modprobe
7echo "gma500_gfx_checked" >> /dev/kmsg;
8
9for DEVICE in $DEVICES; do
10 if udevadm trigger --subsystem-match=pci --verbose --attr-match=device=$DEVICE | grep "pci" >> /dev/null ; then
11 echo "Found $DEVICE, avoiding gma500_gfx module" >> /dev/kmsg;
12 exit 0
13 fi
14done
15exit 1
diff --git a/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb b/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
deleted file mode 100644
index 7b08064b..00000000
--- a/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "Intel gma500_gfx fix for certain hardware"
2DESCRIPTION = "Avoid inserting gma500_gfx module for certain hardware devices."
3LICENSE="GPLv2"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5
6SRC_URI = "file://gma500-gfx-check.conf \
7 file://gma500-gfx-check.sh "
8
9do_install(){
10 install -d ${D}${sysconfdir}/modprobe.d/
11 install -m 755 ${WORKDIR}/gma500-gfx-check.sh ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.sh
12 install -m 644 ${WORKDIR}/gma500-gfx-check.conf ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.conf
13}
14
15FILES_${PN}="${sysconfdir}/modprobe.d/gma500-gfx-check.conf \
16 ${sysconfdir}/modprobe.d/gma500-gfx-check.sh"
17
18COMPATIBLE_MACHINE = "intel-core2-32"
diff --git a/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb
new file mode 100644
index 00000000..60d0dfd2
--- /dev/null
+++ b/recipes-bsp/intel-cmt-cat/intel-cmt-cat_23.11.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "intel-cmt-cat"
2DESCRIPTION = "Software package which provides basic support for Intel(R) \
3Resource Director Technology (Intel(R) RDT)"
4HOMEPAGE = "https://github.com/intel/intel-cmt-cat"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4b63c65942e1c16fd897f8cd20abebf8"
8
9SRC_URI = "git://github.com/intel/intel-cmt-cat;protocol=https;branch=master"
10SRCREV = "b26b31b0ae6980c5939a421cefe0316cae884626"
11
12S = "${WORKDIR}/git"
13
14COMPATIBLE_HOST = '(x86_64).*-linux'
15COMPATIBLE_HOST:libc-musl = "null"
16
17do_install() {
18 oe_runmake install PREFIX=${D}${prefix} NOLDCONFIG=y
19}
20
21FILES:${PN} += "${nonarch_libdir}/libpqos*"
22FILES:${PN}-doc = "/usr/man*"
23
24INSANE_SKIP:${PN} += "ldflags"
25INSANE_SKIP:${PN} += "dev-so"
26INSANE_SKIP:${PN} += "libdir"
27INSANE_SKIP:${PN} += "already-stripped"
28
29INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/recipes-bsp/metee/metee_2.1.1.bb b/recipes-bsp/metee/metee_3.2.4.bb
index 7f06e1f3..da8220b9 100644
--- a/recipes-bsp/metee/metee_2.1.1.bb
+++ b/recipes-bsp/metee/metee_3.2.4.bb
@@ -10,8 +10,9 @@ COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10 10
11inherit cmake 11inherit cmake
12 12
13SRC_URI = "git://github.com/intel/metee.git" 13SRC_URI = "git://github.com/intel/metee.git;branch=master;protocol=https \
14SRCREV = "5ecadbc3d94588dd842b2ef243d597aad644d031" 14"
15SRCREV = "db45e37e146fd9c06907a15ade55eba06ad1f951"
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
17 18
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
deleted file mode 100644
index d2e1c16b..00000000
--- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
1PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
2
3do_compile_append_intel-x86-common() {
4 ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
5}
6
7do_deploy_append_intel-x86-common() {
8 install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
9}
diff --git a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch b/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
deleted file mode 100644
index eaa0da61..00000000
--- a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From dcdaf523393a6e7c07b5a510c573223722b0289b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 1 Aug 2019 08:15:52 +0800
4Subject: [PATCH] Use correct format specifier for size_t
5
6%zu instead of %lu, otherwise on 32 bit:
7
8| In file included from ../git/src/thd_common.h:27,
9| from ../git/src/thd_zone.h:30,
10| from ../git/src/thd_zone.cpp:34:
11| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::update_highest_trip_temp(cthd_trip_point&)':
12| ../git/src/thd_zone.cpp:322:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
13| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
14| | ^~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~
15| | |
16| | std::vector<cthd_trip_point>::size_type {aka unsigned int}
17| ../git/src/thermald.h:82:57: note: in definition of macro 'thd_log_info'
18| 82 | #define thd_log_info(...) g_log(NULL, G_LOG_LEVEL_INFO, __VA_ARGS__)
19| | ^~~~~~~~~~~
20| ../git/src/thd_zone.cpp:322:38: note: format string is defined here
21| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
22| | ~~^
23| | |
24| | long unsigned int
25| | %u
26
27Upstream-Status: Submitted [https://github.com/intel/thermal_daemon/pull/198]
28Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
29---
30 src/thd_zone.cpp | 2 +-
31 1 file changed, 1 insertion(+), 1 deletion(-)
32
33diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
34index dd485d9..eb81d61 100644
35--- a/src/thd_zone.cpp
36+++ b/src/thd_zone.cpp
37@@ -319,7 +319,7 @@ void cthd_zone::add_trip(cthd_trip_point &trip) {
38 void cthd_zone::update_highest_trip_temp(cthd_trip_point &trip)
39 {
40 if (trip_points.size()) {
41- thd_log_info("trip_points.size():%lu\n", trip_points.size());
42+ thd_log_info("trip_points.size():%zu\n", trip_points.size());
43 for (unsigned int j = trip_points.size() - 1;; --j) {
44 if (trip_points[j].get_trip_type() == trip.get_trip_type()) {
45 thd_log_info("updating existing trip temp \n");
diff --git a/recipes-bsp/thermald/thermald_1.9.bb b/recipes-bsp/thermald/thermald_1.9.bb
deleted file mode 100644
index 4f3650fa..00000000
--- a/recipes-bsp/thermald/thermald_1.9.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Use-correct-format-specifier-for-size_t.patch \
18 "
19SRCREV = "7f573b681a25b5ffbe81103ba9fdcf7fec0f2884"
20S = "${WORKDIR}/git"
21
22inherit pkgconfig autotools systemd
23
24FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26SYSTEMD_SERVICE_${PN} = "thermald.service"
27
28COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
29
30CONFFILES_${PN} = " \
31 ${sysconfdir}/thermald/thermal-conf.xml \
32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
33 "
34
35UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"