summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/thermald
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/thermald')
-rw-r--r--recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch37
-rw-r--r--recipes-bsp/thermald/thermald_1.8.bb35
2 files changed, 0 insertions, 72 deletions
diff --git a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch b/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
deleted file mode 100644
index 6897ffc1..00000000
--- a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From bb7631163c8f3f44d0dc83690765cdb799664fd5 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 26 Sep 2018 10:34:15 +0800
4Subject: [PATCH] Use correct format specifier for size_t
5
6%zu instead of %lu, otherwise on 32 bit:
7
8| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::sort_and_update_poll_trip()':
9| ../git/src/thd_zone.cpp:106:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
10| thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
11| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
12| trip_points.size());
13
14Upstream-Status: Submitted
15[https://github.com/intel/thermal_daemon/pull/165]
16
17Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
18---
19 src/thd_zone.cpp | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
23index b7edf9e..cb7b8e8 100644
24--- a/src/thd_zone.cpp
25+++ b/src/thd_zone.cpp
26@@ -103,7 +103,7 @@ int cthd_zone::read_user_set_psv_temp() {
27 }
28
29 void cthd_zone::sort_and_update_poll_trip() {
30- thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
31+ thd_log_debug("sort_and_update_poll_trip: trip_points_size =%zu\n",
32 trip_points.size());
33 if (trip_points.size()) {
34 unsigned int polling_trip = 0;
35--
362.17.1
37
diff --git a/recipes-bsp/thermald/thermald_1.8.bb b/recipes-bsp/thermald/thermald_1.8.bb
deleted file mode 100644
index f7725f31..00000000
--- a/recipes-bsp/thermald/thermald_1.8.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Use-correct-format-specifier-for-size_t.patch \
18 "
19SRCREV = "517c0e5f92d49aeeef3a22b04caf40d588216827"
20S = "${WORKDIR}/git"
21
22inherit pkgconfig autotools systemd
23
24FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26SYSTEMD_SERVICE_${PN} = "thermald.service"
27
28COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
29
30CONFFILES_${PN} = " \
31 ${sysconfdir}/thermald/thermal-conf.xml \
32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
33 "
34
35UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"