summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ace
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ace')
-rw-r--r--recipes-bsp/ace/ace_6.5.3.bb1
-rw-r--r--recipes-bsp/ace/files/config_linux.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/ace/ace_6.5.3.bb b/recipes-bsp/ace/ace_6.5.3.bb
index a75471e1..f1a10eea 100644
--- a/recipes-bsp/ace/ace_6.5.3.bb
+++ b/recipes-bsp/ace/ace_6.5.3.bb
@@ -9,6 +9,7 @@ DEPENDS += "openssl gperf-native"
9 9
10SRC_URI = "ftp://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 \ 10SRC_URI = "ftp://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 \
11 file://ace_config.patch \ 11 file://ace_config.patch \
12 file://config_linux.patch \
12 " 13 "
13 14
14SRC_URI[md5sum] = "4cc5f109ebd17cd56f0539d1b47d16b3" 15SRC_URI[md5sum] = "4cc5f109ebd17cd56f0539d1b47d16b3"
diff --git a/recipes-bsp/ace/files/config_linux.patch b/recipes-bsp/ace/files/config_linux.patch
new file mode 100644
index 00000000..323a63eb
--- /dev/null
+++ b/recipes-bsp/ace/files/config_linux.patch
@@ -0,0 +1,30 @@
1config-linux.h: fix glibc build failure
2
3Recent glibc v2.30 dropped XSI STREAMS declarations,
4which causing below build failure.
5
6poky/build/tmp/work/corei7-64-poky-linux/ace/6.5.3-r0/ACE_wrappers/ace/os_include/os_stropts.h:56:17: fatal error: stropts.h: No such file or directory
7| 56 | # include /**/ <stropts.h>
8| | ^~~~~~~~~~~
9| compilation terminated.
10
11Added GLIBC checks for affected versions.
12
13For more information about glibc v2.30 change, please check:
14https://sourceware.org/git/?p=glibc.git;a=commit;h=a0a0dc83173ce11ff45105fd32e5d14356cdfb9c
15
16Upstream-Status: Submitted [https://github.com/DOCGroup/ACE_TAO/pull/939]
17
18Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
19
20--- ACE_wrappers_original/ace/config-linux.h 2018-11-19 17:45:53.163139000 +0800
21+++ ACE_wrappers/ace/config-linux.h 2019-08-13 17:04:17.620866464 +0800
22@@ -295,7 +295,7 @@
23
24 // Starting with FC9 rawhide this file is not available anymore but
25 // this define is set
26-#if defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1
27+#if (defined(__GLIBC__) && (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 30)) || (defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1)
28 # define ACE_LACKS_STROPTS_H
29 # define ACE_LACKS_STRRECVFD
30 #endif