summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ace
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ace')
-rw-r--r--recipes-bsp/ace/ace_6.5.3.bb40
-rw-r--r--recipes-bsp/ace/files/ace_config.patch12
-rw-r--r--recipes-bsp/ace/files/config_linux.patch30
3 files changed, 0 insertions, 82 deletions
diff --git a/recipes-bsp/ace/ace_6.5.3.bb b/recipes-bsp/ace/ace_6.5.3.bb
deleted file mode 100644
index db150b12..00000000
--- a/recipes-bsp/ace/ace_6.5.3.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "C++ framework for implementing distributed and networked applications"
2DESCRIPTION = "C++ network programming framework that implements many core \
3patterns for concurrent communication software"
4LICENSE = "ACE-TAO-CIAO"
5HOMEPAGE = "http://www.dre.vanderbilt.edu/~schmidt/ACE.html"
6LIC_FILES_CHKSUM = "file://COPYING;md5=407a202d1b887b998dc9480442840630"
7
8DEPENDS += "openssl gperf-native"
9
10SRC_URI = "https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_3/ACE-${PV}.tar.bz2 \
11 file://ace_config.patch \
12 file://config_linux.patch \
13 "
14
15SRC_URI[md5sum] = "4cc5f109ebd17cd56f0539d1b47d16b3"
16SRC_URI[sha256sum] = "b1d6a716394bd15c21bb90037b8a12a4d8034cc9d8878b0ad39b3c467df19b1a"
17
18COMPATIBLE_HOST_libc-musl = "null"
19
20S = "${WORKDIR}/ACE_wrappers"
21B = "${WORKDIR}/ACE_wrappers/ace"
22export ACE_ROOT="${WORKDIR}/ACE_wrappers"
23
24inherit pkgconfig
25
26CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations"
27
28do_install() {
29 export D="${D}"
30 oe_runmake install
31
32 for i in $(find ${D} -name "*.pc") ; do
33 sed -i -e s:${D}::g \
34 -e s:/${TARGET_SYS}::g \
35 $i
36 done
37
38 rm -r ${D}/usr/share
39}
40
diff --git a/recipes-bsp/ace/files/ace_config.patch b/recipes-bsp/ace/files/ace_config.patch
deleted file mode 100644
index 207b85ab..00000000
--- a/recipes-bsp/ace/files/ace_config.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -ruN ACE_wrappers1/ace/config.h ACE_wrappers/ace/config.h
2--- ACE_wrappers1/ace/config.h 1970-01-01 02:00:00.000000000 +0200
3+++ ACE_wrappers/ace/config.h 2019-01-10 13:36:52.698012477 +0200
4@@ -0,0 +1,1 @@
5+#include "ace/config-linux.h"
6diff -ruN ACE_wrappers1/include/makeinclude/platform_macros.GNU ACE_wrappers/include/makeinclude/platform_macros.GNU
7--- ACE_wrappers1/include/makeinclude/platform_macros.GNU 1970-01-01 02:00:00.000000000 +0200
8+++ ACE_wrappers/include/makeinclude/platform_macros.GNU 2018-10-31 15:11:18.265392460 +0200
9@@ -0,0 +1,3 @@
10+INSTALL_PREFIX = $(D)$(exec_prefix)
11+INSTALL_LIB = $(base_libdir)
12+include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU
diff --git a/recipes-bsp/ace/files/config_linux.patch b/recipes-bsp/ace/files/config_linux.patch
deleted file mode 100644
index 323a63eb..00000000
--- a/recipes-bsp/ace/files/config_linux.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1config-linux.h: fix glibc build failure
2
3Recent glibc v2.30 dropped XSI STREAMS declarations,
4which causing below build failure.
5
6poky/build/tmp/work/corei7-64-poky-linux/ace/6.5.3-r0/ACE_wrappers/ace/os_include/os_stropts.h:56:17: fatal error: stropts.h: No such file or directory
7| 56 | # include /**/ <stropts.h>
8| | ^~~~~~~~~~~
9| compilation terminated.
10
11Added GLIBC checks for affected versions.
12
13For more information about glibc v2.30 change, please check:
14https://sourceware.org/git/?p=glibc.git;a=commit;h=a0a0dc83173ce11ff45105fd32e5d14356cdfb9c
15
16Upstream-Status: Submitted [https://github.com/DOCGroup/ACE_TAO/pull/939]
17
18Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
19
20--- ACE_wrappers_original/ace/config-linux.h 2018-11-19 17:45:53.163139000 +0800
21+++ ACE_wrappers/ace/config-linux.h 2019-08-13 17:04:17.620866464 +0800
22@@ -295,7 +295,7 @@
23
24 // Starting with FC9 rawhide this file is not available anymore but
25 // this define is set
26-#if defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1
27+#if (defined(__GLIBC__) && (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 30)) || (defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1)
28 # define ACE_LACKS_STROPTS_H
29 # define ACE_LACKS_STRRECVFD
30 #endif