summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb22
1 files changed, 0 insertions, 22 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
index 5265a9cf..b1a3aea5 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
@@ -1,33 +1,11 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch \
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10
11SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22" 3SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22"
12SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939" 4SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939"
13 5
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 6export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic" 7export ARCHDIR = "generic"
16 8
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
30
31do_install_append () { 9do_install_append () {
32 10
33 install -m 0755 -d ${D}/${INSTALL_PATH}/${RTE_TARGET}/hostapp 11 install -m 0755 -d ${D}/${INSTALL_PATH}/${RTE_TARGET}/hostapp