summaryrefslogtreecommitdiffstats
path: root/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend')
-rw-r--r--meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend b/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
new file mode 100644
index 00000000..f6105711
--- /dev/null
+++ b/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
@@ -0,0 +1,13 @@
1# The Intel provided Fast Boot Firmware may not initialize the USB keyboard
2# before launching the grub.efi payload. Ensure GRUB has keyboard control by
3# building in the usb, usb_keyboard, and ohci modules.
4
5do_deploy() {
6 # Search for the grub.cfg on the local boot media by using the
7 # built in cfg file provided via this recipe
8 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
9 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
10 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search \
11 usb usb_keyboard ohci
12 install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
13}