summaryrefslogtreecommitdiffstats
path: root/meta-dpdk/recipes-extended/dpdk/dpdk_17.05.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-dpdk/recipes-extended/dpdk/dpdk_17.05.bb')
-rw-r--r--meta-dpdk/recipes-extended/dpdk/dpdk_17.05.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-dpdk/recipes-extended/dpdk/dpdk_17.05.bb b/meta-dpdk/recipes-extended/dpdk/dpdk_17.05.bb
new file mode 100644
index 00000000..1a696ede
--- /dev/null
+++ b/meta-dpdk/recipes-extended/dpdk/dpdk_17.05.bb
@@ -0,0 +1,19 @@
1include dpdk.inc
2
3SRC_URI += "\
4 file://dpdk-16.04-dpdk-enable-ip_fragmentation-in-common_base-config.patch \
5 file://0001-examples-Fix-maybe-uninitialized-warning.patch \
6 "
7
8SRC_URI[dpdk.md5sum] = "39c4e1110dd1ef9dab33edbae820f939"
9SRC_URI[dpdk.sha256sum] = "763bfb7e1765efcc949e79d645dc9f1ebd16591431ba0db5ce22becd928dcd0a"
10
11export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
12export ARCHDIR = "generic"
13
14do_configure_prepend () {
15 sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
16}
17
18COMPATIBLE_HOST_linux-gnux32 = "null"
19COMPATIBLE_HOST_libc-musl_class-target = "null"